I'm using a cubieboard with cubian desktop to play video through hdmi output. (cubian is based on Debian 7.0 wheezy armhf, more info here )

the video is fine and I can hear the sound in headphones. I could switch to HDMI sound output (in vlc through : Audio > output > hdmi)

but then the sound become very noisy and I can bearly hear the video sound behind this loud noise :/

cat /proc/asound/cards output seems fine :

0 [sunxicodec     ]: sunxi-CODEC - sunxi-CODEC
                  sunxi-CODEC  Audio Codec
1 [sunxisndhdmi   ]: sunxi-sndhdmi - sunxi-sndhdmi

when I launch alsamixer and switch to "sunxi-sndhdmi" a message says "This sound device does not have any controls."

and I'm stuck... I don't know what to try now

does any one experienced a similar issue ?

I don't know much about sound control on debian so any comment is wellcome :)


I had the same problem and I solved creating a ~/.asoundrc in cubie and adding the next lines:

pcm.!default {
type hw
card 1 #change to 0 to use HP, 1 HDMI
ctl.!default {
  type hw
  card 1 #change to 0 to use HP, 1 HDMI

save and do a test

speaker-test -twav -c2

This is not the best way to enable the HDMI/HP but it works

  • Wow, I don't realy understand what we did here but it worked ! nice answer thanks ! – Guian Apr 13 '14 at 16:26
  • Cool thank you that worked. Afaik it is also possible to move the same content to /etc/asound.conf to have the settings active system wide. – white_gecko Nov 24 '15 at 22:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.