2

I have the same problems as the guys over

How can I start hostednetwork on Windows 7? and Can't get hostednetwork started in Windows 8 x64

But none of the solutions worked for me. I don't know why. I also followed multiple tutorials.

http://www.talkofweb.com/netsh-wlan-hostednetwork-the-hosted-network-could-not-be-started/ http://www.tomshardware.co.uk/faq/id-1879130/turn-wifi-hotspot.html

None of them worked either. The problem: When I'm typing in netsh wlan start hostednetwork I always get the error

The hosted network couldn't be started. The group or resource is not in the correct state to perform the requested operation.

My output netsh wlan show drivers is german, but maybe you can still understand :o

To help: It says under "supports hosted networks = YES"

Schnittstellenname: WiFi

    Treiber                   : Atheros AR7015 Wireless Network Adap
    Hersteller                : Atheros Communications Inc.
    Anbieter                  : Atheros Communications Inc.
    Datum                     : 04.01.2010
    Version                   : 2.0.0.32
    INF-Datei                 : C:\WINDOWS\INF\oem24.inf
    Dateien                   : 1 insgesamt
                                C:\WINDOWS\system32\DRIVERS\athurx.s
    Typ                       : Wi-Fi-Treiber (Ursprungsversion)
    Unterstützte Funktypen    : 802.11b 802.11g 802.11n
    FIPS 140-2-Modus wird unterstützt: Ja
    802.11w Management Frame Protection wird unterstützt: Nein
    **Unterstützte gehostete Netzwerke  : Ja**
    Im Infrastrukturmodus unterstützte Authentifizierung und unterst
hlüsselungsverfahren:
                                Offen           Keine
                                Offen           WEP-40bit
                                Offen           WEP-104bit
                                Offen           WEP
                                Firmenweiter WPATKIP
                                WPA-Personal    TKIP
                                WPA2-Enterprise TKIP
                                WPA2-Personal   TKIP
                                HerstellerdefiniertTKIP
                                WPA2-Enterprise Herstellerdefiniert
                                HerstellerdefiniertHerstellerdefinie
                                Firmenweiter WPACCMP
                                WPA-Personal    CCMP
                                WPA2-Enterprise CCMP
                                HerstellerdefiniertCCMP
                                WPA2-Enterprise Herstellerdefiniert
                                HerstellerdefiniertHerstellerdefinie
                                WPA2-Personal   CCMP
                                HerstellerdefiniertHerstellerdefinie
    Im Ad-hoc-Modus unterstützte Authentifizierung und unterstütztes
lungsverfahren:
                                Offen           Keine
                                Offen           WEP-40bit
                                Offen           WEP-104bit
                                Offen           WEP
                                WPA2-Personal   CCMP
                                HerstellerdefiniertHerstellerdefinie
    IHV-Dienst vorhanden      : Ja
    IHV-Adapter-OUI           : [00 00 00], Typ: [00]
    IHV-Erweiterbarkeits-DLL-Pfad: C:\WINDOWS\system32\athExt.dll
    IHV UI-Erweiterbarkeits-ClSID: {151f7202-8218-4e8d-a685-30f1c62d
    IHV-Diagnose-CLSID     : {00000000-0000-0000-0000-000000000000}

No solution worked for me. Any help?

1

Here is how I did it.

0. About the Wireless Hosted Network

Basically Microsoft changed the way things are handled in windows 8 and 10.

The wireless Hosted Network is a new WLAN feature supported on Windows 7 and on Windows Server 2008 R2 with the Wireless LAN Service installed. This feature implements two major functions:

  • The virtualization of a physical wireless adapter into more than one virtual wireless adapter sometimes referred to as Virtual Wi-Fi.
  • A software-based wireless access point (AP) sometimes referred to as a SoftAP that uses a designated virtual wireless adapter.

These two functions coexist in a Windows system together. Enabling or disabling the wireless Hosted Network enables or disables both virtual Wi-Fi and SoftAP. It is not possible to enable or disable these two functions separately in Windows.

You can read about it more here.

1. Check if your wifi card meets the requirements

At the elevated powershell prompt, type this: netsh wlan show drivers

You should see: http://superuser.com/q/878497/109803

2. Check your services.

You need to check if the following windows services are enabled. Pull up the services screen by typing services.msc in a windows run dialogue box. You can pull it up by pressing the following keyboard shortcut: (Windows-Key + R)

  • run ->services.msc->"routing and remote access" must be set to automatic
  • run->services.msc->"internet connection sharing"->startup type-auto(delayed)
  • (Laptops) Lastly check if your computer's current power plan is not set to battery saving mode. Those profiles can put the wifi card into an energy saving mode, breaking the hostednetwork. In my experience I would have to restart the computer before my wifi hotspot works again.

Now restart your computer to make sure these services are persistently enabled.

3. Set up Hosted Network

Still in the prompt. Type:

netsh wlan set hostednetwork mode=allow ssid=”DESIRED_NETWORK_NAME” key=”YOUR_PASSWORD”

and then

netsh.exe wlan start hostednetwork

You can check the status and number of connected devices by:

netsh.exe wlan show hostednetwork

3. Share hosted network using your wireless card

In a windows run box (Windows key + R), type: ncpa.cpl and press enter.

Right click on the Ethernet connection you want to share and go to properties -> Sharing. Then check the box for "Allow other network users..".

It does not matter if the "Allow other network users to control..." box is enabled.

You probably don't want to share your Home networking connection with your Wi-Fi adapter. Like in this image below.

http://superuser.com/q/878497/109803

Instead you want to select the new connection that appeared after you enabled shared networking above.


You should be done. Check to see if you can now see your new wifi hostspot.

Troubleshooting

If that doesn't work then you have to enable 'ad hoc' support in the wireless card advanced config.

  1. Right click on your wifi connection in the ncpa.cpl screen used above, and go to Properties -> Configure: http://superuser.com/q/878497/109803

A great website that I found that explains what a lot of the variables you see in the advanced tab is: Here

  1. Set the 'ad hoc' variable to enabled.

  2. Set ICS service start mode to auto (delayed):

    • Run » services.msc » Internet Connection Sharing » Startup Type » auto (delayed)

    • Restart your PC or stop/start the service.

This service will load after about 5 mins once Windows starts. It does not immediately start.

  1. Second solution to make ICS work on startup if 3. did not work:

    • Go to Run » services.msc but then, aside from checking ICS service, check for "Routing and Remote Access". If it's on manual you need to set it to automatic – delayed and turned on.

    • By default it was turned off, not even on manual mode.

    • After I changed it to Automatic and pressed Start, Internet started working.

0

Go to device manager, click on view, select show hidden devices. Right click mouse on Microsoft Hosted network virtual Adapter and uninstall. Go to action at top of screen and click scan for new hardware. This will reset the adapter. Now perform the netsh actions as before

  • This did not work for me either. I still can't get any ip addresses assigned to any client devices. – Gabriel Fair Feb 17 '15 at 1:33
  • The above answer is to reset the adapter if it is in the wrong state. – Dave Mar 16 '15 at 16:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.