6

Like this post for Word 2007, we can't save our Word 2013 document to PDF and simply receive a generic error:

enter image description here

Is there any way to troubleshoot this error? Playing around with the conversion options hasn't helped, although I was able to narrow-down the issue by printing a range of pages and finding "suspicious" content: in this case, it seems to be a complicated diagram built using Word Drawing Art [or whatever it's called?] which the PDF parser mustn't be able handle.

We're also going to look at Office 2013 SP1, but I'm not sure it'll help.

14 Answers 14

2

I've also run into this issue, where Word would suddenly stop saving PDF files using the Save As function.

As I had a large and complex document I needed to compile into PDF on a strict deadline, and as Word didn't tell me which page it became stuck on (a tip mentioned elsewhere in this stack), the following helped me quickly find which page the Word was failing on:

Export the document to PDF in 'blocks'

Note: before you do this, ensure you save a backup (in .docx) somewhere safe first.

Just before pressing Save to transform a Word document into a PDF document using Save As, select Options...

PDF Save Options in Word

Use the Page range setting to export 'blocks' of the document to see if it works. That will help you narrow down which page Word is failing on.

For example, if you have a 100 page document export pages 1-50 first, then pages 51-100 second. Ensure you try to export the 51-100 'block' even if Word fails on the 1-50 'block' straight up, to exclude any issues in the second half of your document.

If Word fails in the 51-100 'block' but not the 1-50 'block' you know that it's the second half of your document causing the issue.

Keep doing this with increasingly smaller 'blocks' (e.g. 51-70, 71-100 and so on...) until you've narrowed it down to two or three pages.

In my situation I was able to export Page 1, and Pages 7-100 successfully but not the whole document. So I knew the problem existed between Pages 2-6.

Then start removing sections (text, images, tables, headings, hidden formatting), without saving the document to .docx, then try exporting the whole document as PDF again. If it works and Word exports the document successfully, the corruption was in the section you've just deleted.

If Word fails to export to PDF, go back to the document, hit Ctrl + Z to undo the section you've just deleted then repeat by removing another section and exporting the whole document as PDF again.

Rinse and repeat until you can export the document successfully.

Turns out the issue with the document I was working on either was a table, an image, or a section break as the issue seemed to be between two pages.

Also consider Headers and Footers as well, they may become corrupted too. Also found a large image pushed off at the very top of the first page, that wouldn't show when exporting the document to PDF normally, but would show up when exporting the document to PDF with revision comments. Somehow an image got in the revision comments section... shrugs.

1

It was because you are using custom fonts, try CTRL+A and change all fonts to something like "Arial". If you had header and footer, make sure to change that font as well. Somehow the PDF converter not able to convert if the fonts was not default from Microsoft.

0
1

I can't answer for anyone else, but I know Google users arrive here frequently, and I'm going to explain to them how I fixed this for my 600-page document filled with custom formatting, custom fonts and headers. I wasn't about to copy the contents into a second document and risk losing anything; the proofreading would take more time than I had going spare. Printing to PDF would have lost the hyperlinks scattered throughout the document. Images and constructions were integral to understanding what was being written about. In essence, "just do this" answers were not an option.

I set the permissions for t2embed.dll as others here note, but I can't say how much good it did. Word 2016 was alternating between giving me an error ("The export failed due to an unexpected error") and turning white and crashing. It crashed every time I tried to export, it was just a question of when. The program was producing a .TMP file in the directory I was exporting to, but after a few seconds it would vanish and progress would halt.

Eventually I decided to stick a camera up to my screen and film the output in the bottom-right. First it would enumerate the pages, then parse the links, and then slowly increment a counter for which page was being exported. This is assuming the program's interface hadn't crashed, so it took a few attempts. Eventually I found that the last number it was displaying before crashing was page 335. There was nothing strange about page 335, but replacing its contents with "removed to fix PDF export" caused the export to work fine.

Eventually, I copied the contents of page 335 to Notepad++ and changed all the quotation marks and apostrophes (which Word replaces with spicier versions) into normal ones. I copied it back as plain text and removed the hyperlinks. It worked. For some reason, that particular page had become corrupted and wouldn't export. Re-producing it worked.

1
  • +1 Because this sounds plausible. I'm going to try it and love the idea of filming the display to get determine which page it is puking on. – Eric Hepperle - CodeSlayer2010 May 29 '18 at 15:21
1

I had this issue when trying to export a manuscript with custom page size, tables, images, and custom fonts. I successfully saved several version as PDFs in the process of creating the file and making edits. For some reason, the export process stopped working. After reading this thread, I tried a few things with the settings, and even tried to change out a few of the recent images I had included since the last successful export. It wasn't until I started exporting specific pages at a time that I found the issue.

Page 9 had text, but no images, and had been in the manuscript since its creation. When I was redoing the page, I noticed the font formatting at the end of the previous page had switched to something that started with "UF" and looked like Times New Roman, even though I had never formatted either of those into the document. I got rid of the lines that had the weird font (albeit no text there), inserted a new page with the original text that kept the proper formatting, and I'm back in business now.

0

In my case it was due to an image in the document had become corrupt. We don't know how this image became corrupt (it was a large document that had been last edited a few years back), but any attempts to "save as PDF" gave the error.

Removing the corrupt image allowed the file to be saved in PDF form successfully.

0

In my case it was due to enabling the "Track Changes" feature.

If you have enabled tracking changes in MS Word, just disable it and try to save as pdf again.

It works :]

(Word 2013)

0

Similar to Bummi, I had this issue and it was resolved by a user having a blank table cell by itself to serve as a "Checkbox" option beside YES or NO. I replaced these with a regular symbol instead of a blank table, and the issue was resolved.

(Office 2016, click to run. 16.0.6701.1034 32-bit)

0

try this ---- find word docx file in windows explorer and right click on file and then click on convert to pdf in drop down window --- I have Word 2013 and this seemed to work a treat.. good luck -- junglemac

0

After reading the posts here, I investigate and found out. My problem (in WORD 2016) was because a text box places on an image.

I erased the text box and it is OK. Now I am able to save as PDF.

0

I just figured out I was receiving that error because I had upload an image to use for bullet points, I had to change the bullet points back to a classic Word option

0

I'm not sure why @SathOkh's answer was down-rated since this is usually the case for me. (Sorry, I don't have enough reputation to comment directly on the post)

For me, the combination of answers for @seagull and @SathOkh was sufficient to help pinpoint the problem:

  • First I checked that I didn't have any custom fonts
  • Then, checked that there weren't any links to external documents (File menu, Edit links to documents, under the list of properties)
  • Then tried to export to PDF again and watch the status bar to determine the exact page number that caused the problem.
  • On that page, I found an image that had been pasted using the Paste Special/Picture (Enhanced Metafile) option. I deleted the picture and pasted it again using Past Special/Picture (PNG) and then the PDF conversion succeeded.

PS: I use track changes on word documents all the time, and they still do convert to PDF.

I wish that MS would include more diagnostic information in their error messages though so it could tell you exactly where it failed.

-1

In my case it was due to images and pictures.

I had to remove and import (paste) again some images in the text. I was able to find the images causing the problem by printing only some pages and checking which images caused issues.

Changing fonts, as well as setting permissions for windows\system32\t2embed.dll (another sugessted fix from internet), did not help.

-1

Filming the export process in the right corner is a helpful idea because you can see on which page it goes wrong. For me it was an imported EMF file that made the export failing.

-1

change file path to windows drive ( not other drive) . for example: if windows installed in drive (C) you mast be change save position to drive c . a folder like download or user.

FILE – EXPORT – CREATE PDF/ XPS – (CHANGE FILE POSITION / PATH)- OPEN- PUBLISH

…………………………………….. مسیر ذخیره فایل را به درایوی که ویندوز در آن نصب است تغییر دهید و براحتی و با کیفیت بالا فایل ورد را به پی دی اف تبدیل کنید

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.