22

Lately when I download a PDF in Chrome and click the downloaded file in the bar at the bottom, it opens in chrome. I would like it to open in adobe as default, since I download mostly files with comments or stuff Chrome doesn't support anyway. I have seen this, but it makes chrome download all files and open them in Adobe.

So what I want is: if I click a random PDF, it should open in the chrome browser, if I click a downloaded file from the bar at the bottom or from chrome://downloads it should open the file in Adobe. (Just as it used to be two weeks ago). Is that still possible?

18

FYI for others: if you're okay with the Chrome PDF viewer, but want only downloaded PDFs to open in your external PDF viewer (Adobe Acrobat, Foxit Reader, etc.), you don't need to disable the Chrome PDF Viewer.

Always open PDFs using your system's viewer

Simply click the arrow next to a PDF download and select the option to use the system viewer.

Always open with system viewer

Turn off auto-open of PDFs in the system viewer

UPDATE 6/7/2017

As of Chrome version 59, the option below doesn't exist in Settings. I'll leave these instructions, because if they ever add it back it'll probably be in the same place.

  1. Click on the Chrome Menu icon Chrome hamburger icon
  2. Click on Settings
  3. Scroll down and click Show advanced settings
  4. Scroll down to Downloads. If you have enabled any file types to open using the system viewer, you'll see a button to Clear auto-opening settings. Clicking this will reset the settings for all file types.

Download settings

More info

Relevant SuperUser discussion here: How to automatically open "saved" pdfs in system viewer on chrome?

  • When I do this, it not only applies "always" to "with system viewer", but to "open". – mwchase Apr 26 '18 at 0:27
10

You should try this:

  1. Open Chrome.
  2. Type chrome://plugins/ in the address bar, hit enter.
  3. Browse the list for Adobe PDF viewer or Adobe reader (and chrome pdf viewer)
  4. Disable both (although disabling adobe reader would work alone.)

Hope this helps.

  • Done all versions of the two. Neither gave me what I wanted. Disabling 'Adobe PDF reader' made it download all PDFs. – Ramzi Kahil Apr 4 '14 at 12:24
  • Right click a pdf file on your system. Select Open with > choose a default program > Click on adobe reader. After this whenever you would click the downloaded file, it would open as a solo file outside of chrome in Adobe reader. – Sandman Apr 8 '14 at 7:48
  • I think you didn't understand what I want... – Ramzi Kahil Apr 8 '14 at 10:02
  • Did you mention where that 'random pdf' is located? or What that random pdf signify? If your 'random pdf' is outside of chrome and you want it to open in chrome. You just have to change the default program. And in my experience, you can't have two default programs for two different situations for a single file type. – Sandman Apr 8 '14 at 10:33
  • Random PDF=A PDF file that I have not downloaded. What is want is this: I click some PDF -> opens in chrome ;; I click at a PDF that I downloaded (in the bar at the bottom) -> opens in Adobe. – Ramzi Kahil Apr 8 '14 at 17:33
5

In Chrome, type chrome://plugins/
Find the Chrome PDF Viewer and click Disable
From your browser, click a PDF file; it should show at the bottom as a downloaded file.
Click the arrow next to the downloaded file, and choose Always open files of this type (You may need to manually click Open on any recent files you want to view, otherwise...)
The next time you click a PDF file, it should open however your computer is configured to open PDF files. If that method is via Adobe Reader or Adobe Acrobat (standard, pro), then that should meet the need you expressed in your question.

2
1- Go to chrome://settings.

2- Click on "Privacy" --> "Content Settings".

3- At the bottom, click on: 
"PDF Documents" --> "Open PDF files in the default PDF viewer application".

This should solve the problem!


PS:

1- Instead of 1 & 2, you can navigate to: chrome://settings/content

2- You can click on the file name's small (upside) arrow in the "Downloads bar" at the bottom, and, click on "Always open with system viewer". However, this works only for this downloaded file, not other downloads (it should be a bug though)!

3- After doing the above three steps, when you click on a file in the download bar, it first opens another tab and closes it quickly (another bug, which is a little annoying)! But then opens the file in your PDF viewer anyway.

4- Previously you could control this from chrome://plugins which is now removed from Chrome (57 and later versions). So you just ignore what you found on the web about chrome://plugins.

  • 2
    this is answer for more recent versions of chrome. – assylias May 26 '17 at 8:23
  • what if this option is not there? I only see the option to Download instead of Opening a PDF... – Philippe Jan 11 at 16:13
  • It is in the "Contents settings". To find it, you can search in the provided edit box (i.e., type "Ctrl+F" and then "PDF Documents", then press enter). – Alisa Jan 12 at 22:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.