2

I am trying to source my zshrc. It sources fine when before I add this line:

. ~/Dropbox/configs/aliases

Then I get this:

/Users/mkrell/.zshrc:.:13: too many open files: Dropbox/configs/aliases
/Users/mkrell/.zshrc:source:53: too many open files: /Users/mkrell/.zshrc`

My $PATH variable is /Users/mkrell/bin:/usr/local/bin: repeated over and over again.

I attempted the advice of moving everything out of /etc/paths.d/ to my Desktop, as said in this thread:

Mac OSX Mavericks - ZSH can't 'source ~/.zshrc', too many open files

and restarting. No change whatsover.

This started to happen after I ran BundleInstall on this guy's .vimrc

Immediately after this iTerm2 would always give me the error message

A session ended very soon after starting. Check that the command in profile "New Profile" is correct.

and close immediately. I would change the profile and it would still do this.

To solve this, I moved ~/Library/Preferences/com.googlecode.iterm2.plist to ~/Library/Preferences/com.googlecode.iterm2.plist2and that solved it, but then I got the behavior I described originally.

I have deleted every .vim file and reinstalled .oh-my-zsh but I am no nearer the solution.

  • 2
    What's in ~/Dropbox/configs/aliases? Specifically, does it do anything that'll source ~/.zshrc? This sounds like an infinite source recursion to me... – Gordon Davisson Mar 31 '14 at 16:07
  • Ohh, I think your right! # source alias source="source ~/.zshrc" There's a bunch of other stuff to but this might be it. – mkrell Mar 31 '14 at 16:58
  • YAY! That did it! Deleted that line and all is working! THANK YOU THANK YOU THANK YOU! I <3 Stack Exchange! – mkrell Mar 31 '14 at 17:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.