0

When opening Microsoft Office files on one of our SMB servers, occasionally Office will show the following error:

This file is locked for editing.  
Locked by: another user  
Filename: File.docx  
You can open the file as read-only.

I've narrowed the issue down to the file having a read/write lock placed on it on the SMB server while the thumbnail of the document is rendered within Finder in Column view. When double-clicking a file that isn't already selected, Finder tries to render the thumbnail in the details column while Word is trying to open the file at the same time.

Sometimes Finder renders the thumbnail and releases the lock quick enough for Office to open the file normally. Other times the lock is held for too long and Word cannot open the file, causing the above dialog.

If the file is already selected, the thumbnail is already rendered, the file isn't locked on the server and Office can open the document fine. This is the current workaround I've given users who are affected.

Looking in syslog, whenever this issue occurs the following error is logged:

Apr  1 09:22:51 localhost kernel[0] <Debug>: FindFileRef: pid not matching 
--- last message repeated 12 times ---

Every time a file is selected (but not necessarily opened) the following message appears:

Apr  1 09:37:38 localhost Finder[171] <Notice>: [QL] After retry, preview was from a different type for <QLPreview 0x7ff5d871e170 57139 file:///Volumes/user/File.docx>

Anyone encountered this before or have ideas on how to reduce this issue?

1

Updated: Microsoft Office support for macOS 10.14 Mojave

Looks like Office 2011 is not maintained for new macOS 10.14 Mojave, so might consider to use Office 2016/2019/365 instead of Office 2011.


Found this issue too, the environment is macOS 10.14.4 and Office 2011, and docx files are placed on a remote NAS. When macOS opening the docx files on remote NAS through AFP mount or SMB mount, Office 2011 would prompt a windows said:

This file is locked for editing.
Locked by: another user
Filename: test.docx

You can open the file as read-only

Found that macOS disable Finder preview function could way around this issue. 3 steps as following:

  1. macOS > Finder > View > Click 'Hide Preview'.
  2. macOS > Finder > View > Show View Options > unchecked checkbox 'Show icons' and unchecked 'Show icon preview'. There is a button 'Use as Defaults' at the bottom, click it if required.
  3. macOS disconnect the SMB/AFP mount first; then connect SMB/AFP mount again.

enter image description here


enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.