I'm using Windows 7 32-bit, Toshiba Portege laptop.

I want to connect to the WiFi, usually I can do that easily. But, I don't know.. maybe when I tried to install a Microsoft Research: Mesh Virtual WiFi that could connect more than 2 wireless networks. I wanna try in connecting both Wireless router and my personal Ad-Hoc.

Now, my laptop don't recognize my WiFi, well, I can connect to the WiFi but it says: "Limited access" and doesn't really connect to the internet. But when I plug the LAN cable, it works. I know the problem is in the laptop's wireless connection or in the properties. Any help for this?

UPDATE: The IP and DNS settings, I set to automatic, and when I ran diagnostic, Windows tells me that the wireless network adapter is the problem, but they told me to insert the LAN cable, so how to fix the wireless? They didn't tell me how to fix that.

  • Have you tried to reverse the steps you've taken to get to this point? Seems something you've done has likely caused this. You need to verify what you installed caused the issue before you blame the hardware. Also, ensure your computer is compatible with what you are trying to do. After you've done those things, please update your question to include those details.
    – CharlieRB
    Apr 1, 2014 at 11:20
  • @CharlieRB I did uninstall the software, that Microsoft Research Mesh Virtual WiFi (I just remember that). And the problem remains the same. My computer is compatible, I mention that.
    – aldy505
    Apr 1, 2014 at 11:37
  • Sorry, I don't see where you state it's compatible. Nevertheless, have you tried System Restore to a date when it was working. The installation may have changed some drivers.
    – CharlieRB
    Apr 1, 2014 at 11:51
  • I tried that. Still occur the same problem.
    – aldy505
    Apr 2, 2014 at 7:40
  • I found the answer here: superuser.com/questions/102632/…
    – JinSnow
    Nov 3, 2016 at 10:04

5 Answers 5


Remove the Wireless adapter's drivers.

  1. Press Windows Key + R to get the Run command.
  2. Type devmgmt.msc and press Ok or hit Enter
  3. Locate your wireless adapter by expanding out Computer Name -> Network Adapters and look for something that may indicate WiFi adapter.
  4. Single, left click on the adapter and press Delete
  5. If there is a Confirm Device Uninstall Press Ok to confirm you want to uninstall the device. ***See foot note
  6. Reboot.
  7. Driver should automatically re-add and say new hardware found. After the WiFi adapter has been reinstalled verify if the connection works.

An alternative solution to determine if it is the WiFi adapter or your WiFi access point is to download something like Ubuntu. It is small and can be installed on a thumb drive. Boot from the thumb drive and verify that wireless works through it. If it does we can establish that this is a Windows issue and not a hardware/router issue.

*** If after reboot this does not work go back through the steps again and check "Delete the driver software for this device" and click Ok on the Confirm Device uninstall. Ensure you have the driver downloaded in the event that Microsoft Update may not have the driver. You may have to point to the location of the driver on re-installation.

  • I've uninstall Microsoft Mesh VirtualWiFi (from devmgmt.msc), which I think it's the problem, but it doesn't works. The others, I have Realtek RTL8187SE Wireless LAN PCIE Network Adapter, and Atheros AR8132 PCI-E Fast Internet Controller. I think I should reinstall the Realtek one, but I checked that it's up to date. What should I do?
    – aldy505
    Jun 7, 2014 at 5:04
  • you should uninstall the Realtek Wireless Network Adapter drivers and re-install them and see if that fixes the problem.
    – Vinayak
    Jun 9, 2014 at 10:45
  • @Vinayak: the problem about uninstall the Realtek drivers is: I don't remember if I had the installer. But I remember it's there when I bought the laptop.
    – aldy505
    Jun 9, 2014 at 10:56
  • Here's the driver: realtek.cz/realtek-download.php?realtek=RTL8187SE&system=5
    – Vinayak
    Jun 9, 2014 at 11:25

Is anything else connecting to your WIFI (Phones, Tablets, other laptops...) Are you sure it's your Laptop and not your wifi router/access point?

Normally, windows gives you "connected" but "limited Access", after it has successfully associated (connected wirelessly) to the acual router/access point, but cannot reach "Da Intarwebz" (I hate how windows errors - they're soooo fuzzy and meaningless)

This means that WEP/WPA/WPA2/EAP/802.1x has gone through and the Wifi router has let you in, but for some unknown reason Windows cannot get out.

It might be, as other mentioned above, a problem in windows itself, but as I'm not an expert in that particular OS, I'll give you pointers on the WIFI/routing part:

  • If nothing else is connected to the wifi router:

It might be that you're not given an IP address or default gateway (or DNS entries)

Are the Wired/Wireless connections on the SAME device (are you hooking up your laptop to the wireless router?)

If that's the case, you can check with "ipconfig /all" if you received any DHCP information on your Wireless. (locate your Wireless adaptor entry, note the information. connect with the cable, do the same thing for that network adaptor too)

They normally should match what you get from your LAN connection (different network adaptor, but the IP should be in the same range and the rest of the config should match pretty much). If there is a difference, it could be that the WIFI config has a different DHCP config (different parameters or is simply disabled on WIFI)

  • If other things are connecting, check for MAC Filtering on the wireless box, it might be set-up to only let through specific MAC (might have been enabled by error or configured by someone else...)
  • The problem is in the laptop, I connect my phones and my brother's laptop, and it works. But not in my laptop.
    – aldy505
    Jun 7, 2014 at 5:05

Make sure it's getting an IP automatically (or has the right static IP if applicable). Make sure it has all the IP information - including Default Gateway and DNS.

  • I did, actually.
    – aldy505
    Apr 2, 2014 at 7:48

if your system is in domain and having domain authentication then it could be profile issue. You can logon with another user's profile and check. All other tshoot steps have been added already.


First open the browser then go to 'Options' -> 'Settings' -> 'Show advanced settings' -> 'Network' -> 'Change proxy settings' -> 'Internet properties' -> 'Connections' -> 'LAN Settings'

Uncheck all the three options in this windows.

Then click ok and restart the browser.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .