Only files on my harddrive are opening as read only. This only happens when my hard drive is connected to my laptop. When my hard drive is connected to the schools computers it just opens all the files normally. I can't manage to save anything. Does someone know what is going wrong? I've went through some solutions on superuser but I can't find a solution. Also when I try to save for instance a php file(notepad++) I get an error:Save failed. Check if the file is opened in another program


You probably don't have the rights to write to the harddisc.

Check the properties of the drive and go to the security tab, the group "authenticated users" should have modify permissions, if not click edit and assign those rights.


Right click on the file whilst it's on the external harddrive (at home) and change the properties from Read-Only (uncheck the box)

Or, select all the files or the folder the files live in and remove the readonly check.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.