0

I have additional shared mailboxes added to Outlook 2010. These are added by the Outlook autodiscover function. The mailboxes are stored on Office 365 and I have Full Access rights.

Unfortunately, when expanding some of the mailboxes in Outlook, what I see is the contents of the mailbox for my account rather than the contents of that mailbox.

I'm an admin on our Office 365 tenancy, so I have been able to remove the rights which results in the mailbox being removed from Outlook. But when I add the access rights back, the mailbox continues to display the contents of my own mailbox.

Any ideas?

2

As far as I can tell this is a bug in Office 365. It worked for us for a year and then it started happening to most of our users who have Full Access to shared mailboxes.

The only way I know how to get around this is to assign full access to a group instead of a user, place the appropriate user accounts into that group, and give the group Full Access permission. There are other ways to disable auto mapping in Outlook, but this seems to be the easiest way.

Since Outlook won't automatically display the shared mailbox when a group has Full Access permissions, users can add the shared mailbox to their mailbox (http://www.groovypost.com/howto/microsoft/add-a-second-additional-mailbox-in-outlook-2010/).

Here's another post about the issue; no solution as of yet: http://community.office365.com/en-us/f/148/t/169225.aspx

Miles

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.