1

Scenario:

  • Windows Vista Basic installed on Hard Disk
  • Created a partition (after Windows Partition - i.e Windows is in the 1st Partition)
  • Installed Linux Mint Cinnamon 64-bit (UP6) on new partition
  • Grub2 ( I assume) gets installed and presents the selection screen at boot time
  • Four options available,
    1. Linux Mint
    2. Linux Mint Recovery
    3. Windows Vista
    4. Windows Vista Recovery
  • Selects Windows Vista (Linux Mint Loads Fine and can see Windows partition and all data from Mint)
  • Sees GRUB _ i.e "GRUB" followed by blinking cursor
  • Reboots the machine by hardware shutdown

  • Selects Windows Vista Recovery
  • Performs StartUp Errors Correction (Correction done, indicates some files were corrupted and were fixed)
  • Reboots the machine again

  • Sees Some ASCII characters (looks like smiley face) and blinking cursor. Please note no GRUB selectoion screen was presented this time.
  • Reboots the machine by hardware shutdown

  • Uses Linux Mint Live USB and reinstalls Linux and GRUB (Linux Mint doesn't have any important data so reinstalled on the same partition)
  • Reboots the machine again

  • Selects Windows Vista Recovery
  • Selects command line option
  • Uses bootrec /fixmbr
  • Uses bootrec /fixboot
  • Both says operation completed successfully
  • Also bootrec /scanos says no windows installation found
  • Reboots again and chooses Windows Vista

  • Sees GRUB _ i.e "GRUB" followed by blinking cursor
  • Reboots the machine again

  • Selects Windows Vista Recovery
  • Performs System Restore to earlier Restore Point (Hoping it will magically overwrite wherever needed and fix the MBR)
  • Reboots the machine again

  • Sees only a blinking cursor
  • Uses LinuxMint Live USB and reinstalls on Linux Mint partition

Plan:

  1. Try to install Ubuntu on the same partition as Linux Mint (Overwrite Mint) . Don't know if this will help.
  2. Use a Linux Mint/ Ubuntu live USB and Delete the partition for Linux Mint

Question:

If I go with the 2nd option how will I boot into my machine? By deleting the partition I'll remove GRUB as well.

I assume I will face a screen wit blinking cursor as happened after System Restore.

If this is not a proper solution what should I do?


Note:

  1. Cannot overwrite Windows Vista. Have lots of data which will be a pain to migrate
  2. Have tried update-grub etc . Still the same

UPDATE 1:

Installed Ubuntu 12.04 (No more Linux Mint)

fdisk -l
Disk /dev/sda: 320.1 GB, 320072933376 bytes
255 heads, 63 sectors/track, 38913 cylinders, total 625142448 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disk identifier: 0x28beed33

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *          63   391968767   195984352+   7  HPFS/NTFS/exFAT
Partition 1 does not start on physical sector boundary.
/dev/sda2       601681920   625135615    11726848    7  HPFS/NTFS/exFAT
/dev/sda3       391970814   601681919   104855553    5  Extended
Partition 3 does not start on physical sector boundary.
/dev/sda5       595681280   601681919     3000320   82  Linux swap / Solaris
/dev/sda6       391970816   595679231   101854208   83  Linux

Partition table entries are not in disk order

Disk /dev/sdb: 8103 MB, 8103395328 bytes
250 heads, 62 sectors/track, 1021 cylinders, total 15826944 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x000c2948

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1   *          62    15825499     7912719    c  W95 FAT32 (LBA)

Note: Due to emergency I had to restore my machine to the factory state.So I can't personally try out any more suggestions. However, I am leaving this question here for anyone else facing a problem.

  • Have you tried mounting the Win partition in Mint to see if everything is at least still there? If it is, then I would guess that your partition local MBR for the Win partition was overwritten. I've never heard of this happening before and I'm not sure as to how to fix it. But do make sure there is something to recover before you get rid of Mint, so you're not left with an OS-less computer. IIRC, Test Disk is capable of restoring MBRs. – Tyler Apr 3 '14 at 15:18
  • Why are you picking windows recovery instead of windows? In this situation, grub2 should be the working boot manager. When you use the windows recovery, part of that operation is wiping out grub and loading the windows bootmgr (that will never know about Linux). Your goal should be to fix grub to recognize vista. Is that what you are trying to do? – jdh Apr 3 '14 at 15:20
  • @tyler Yes all my data is still there in the Windows Partition. I guess I need to backup my data on external drives and reinstall Windows,if nothing works out – Suvarna Pattayil Apr 3 '14 at 15:27
  • @jdh Yes actually I do want Grub to recognize Vista. Whenever I select Windows from GRUB options, I encounter "GRUB _" . Since Linux Installation is fresh I can afford to overwrite it / remove it. But I prefer fixing grub to recognise Vista. – Suvarna Pattayil Apr 3 '14 at 15:30
  • Any chance when you installed Mint, you picked the "along side" option instead of the "something else". The former installs inside the windows NTFS, and the later prompts for a destination partition. What happens when you pick the boot option to run Mint? What hardware are you using? Have you tried modifying the boot options and running in compatibility mode? Assume the partitions are NTFS for Vista (1st primary) and Ext4 for Mint (extended)? – jdh Apr 3 '14 at 17:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.