I have an SMI file that contains subtitle translations for 9 languages. The original file is using UTF-8 encoding, so viewing the text file in Notepad displays fine.

I have the SMI file and a WMV video with the same name, so the video uses the SMI file for subtitles and gives me the subtitles dropdown list for all languages in the SMI file (as desired): enter image description here

However using this encoding, only English displays correctly. Any language text with special characters is displayed in like a Wingdings font.

enter image description here

I've tried resaving the SMI file into multiple encoding formats.

When saved as ANSI, languages like French, Spanish, Italian, and German that have special accents save correctly in the file and display in Windows Media Player. All Asian characters are turned into "?".

enter image description here

When saved as UCS-2 (Unicode), all languages display fine in Notepad, but then WMP doesn't recognize the SMI file anymore, so no subtitles are available.

enter image description here

How can I encode the SMI text file so that all languages are saved in there and displayed properly in Windows Media Player? It seems that WMP is converting everything to ANSI when displaying the subtitles.

I must use the SMI file and Windows Media Player - it is out of my control.

  • In Control Panel - Region and Language, please try setting the language under Format to Korean (Korea) and reboot. Does WMP correctly display the Korean subtitles afterwards? – Tim De Baets Apr 4 '14 at 19:05

Apparently, the answer to this question is no - it can't be done.


I also emailed our video software's technical support and this was their response:

Note that most sites (Microsoft included) don't recommend Windows Media Player for playing files with Closed Captions; they recommend embedding closed captions into the video (which WMV files don't support) or to use a more powerful media player like VLC Media Player, or lastly, to create the videos as Silverlight web pages (which, with work, can include captions). There really is no easy way to turn captions on in Windows Media Player.


It is possible. You just need to use html code of the Unicode characters. You have to think that sami itself is an utf-8 file without Unicode support (because if you put Unicode values, they are not parsed and displayed properly using Windows Media Palyer). However, you can display all kind of Unicode characters supporting all languages using html code for all alphabets. This can be tedius job. If you can script this or write code in a programming language this can be easier.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.