1

I'm using Debian Squeeze, was trying to update automake and then in the process of configuring found that autoconf was too old. Trying to install autoconf, I get this:

apt-get install autoconf
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package autoconf is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'autoconf' has no installation candidate

I updated the sources.list from Debian Sources List Generator (http://debgen.simplylinux.ch/)

I could use some help figuring this out. Ultimately I am trying to install smarttools and I can't because automake.

./autogen.sh

You must have at least GNU Automake 1.7 (up to 1.13) installed
in order to bootstrap smartmontools from SVN. Download the
appropriate package for your distribution, or the source tarball
from ftp://ftp.gnu.org/gnu/automake/ .

Also note that support for new Automake series (anything newer
than 1.11) is only added after extensive tests. If you live in
the bleeding edge, you should know what you're doing, mainly how
to test it before the developers. Be patient.

Here's the sources.list deb http archive.debian.org/debian oldstable main contrib non-free deb-src http archive.debian.org/debian oldstable main contrib non-free

deb http ftp.debian.org/debian/ squeeze-updates main contrib non-free
deb-src http ftp.debian.org/debian/ squeeze-updates main contrib non-free

deb http security.debian.org/ squeeze/updates main contrib non-free
deb-src http security.debian.org/ squeeze/updates main contrib non-free

I had to remove the : / / protocol delimiters to post the details

  • 2
    Can you post your /etc/apt/sources.list ? – Bolli Apr 4 '14 at 13:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.