0

Problem: I have a laptop. It works very well on AC power, but on battery power, it powers off in a few minutes, if not seconds, without warning.

I saw lots of similar problems not only from SU, but from other websites: link1 link2 link3 link4 ..., where none of them were resolved yet.

In many of such links, people suspect 'a fan problem,' but I doubt it, because it never happens on AC power. On AC power, I run very heavy programs that use all of 4 cpus with hyperthreading, (so CPU usage 800%) without power off even a single time.

To describe my system a little bit more,

  • it is ASUS N55SF (15", i7 quad core, 8GB, and I added SSD).
  • I use Ubuntu 12.04, and I strongly suspect this might be a problem, but no evidence yet.
  • Once, I have used a Targus charger (19V 4A) for a few weeks instead of the original charger (19V 6A), and from this time the batter calibration got mangled, but not sure if it is related.
  • I fully charge, and the battery history graph indicates 100% charge, and it shuts down a few seconds later on battery. When reconnected to power and powered on, battery meter indicates 100% again. Measured with multi-meter, it IS full.
  • The charger output voltage is 19V, but the voltage in software battery meter is 11V. Could this be a problem?

As N55SF doesn't have a battery calibration, I did manual full charge and discharge some times, but no help.

I got a new (supposedly unused unless the seller is lying) battery from ebay, and I still have same problem (even worse). I got the battery from ebay because ASUS doesn't have its official store, as far as I know.

With all pieces of information gathered, I tried to rebuild the scenario like this:

  • it powers off without warning --> sensor does not recognize the batter voltage lowering?
  • Maybe battery output voltage fluctuates, and maybe a protection circuit against it is broken?

but still no clue.

For now, I got another cheap laptop ($200) for mobile use, and gave upon using the main laptop on the go. However it will be great if I could fix this problem.

0

At first sight it simply looks like a dead battery. You can see the battery health by clicking battery icon in the system tray (upper-right corner) and choosing Battery position in menu. Then search for Energy (design) and Energy when full. The first value is the brand new battery capacity, and the second one is the actual battery capacity. If it is close to zero it means battery end of life and you need to get a new one.

You didn't tell whether the battery you bought on eBay is the brand new one or used one. Anyway, check it as I described. If battery health is good, it may be a problem with Ubuntu itself. The upgrade to actual version 14.04 is good first step.

Can you reproduce your problem on MS Windows?

  • Thank you, and I modified for clarification. I did the check: Energy (design) 57.2 Wh, Energy 31.1 Wh. I cannot run MS windows immediately, I'll try that during the weekend or so. – user3477691 Jun 17 '14 at 18:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.