Whenever I insert a pen drive, I am not able to open it.

Vista shows me this error:

Please insert disk into removable drive

I have tried changing the drive letter, but it didn't help.

  • Ugh, this brings back bad memories of a DOS system of mine that while running off the hard drive suddenly said "Please insert disk into drive C:". :-( Jan 21 '10 at 14:02
  • I am having the same problem. Just adding this in case it helps anyone else. I was sharing this drive with a VM using MS Virtual PC and I kept attaching/releasing they day before the drive quit. Not sure if this was the cause as the drive had been acting flaky before. It is corsair Flash Voyager 32gb.
    – Dan
    Aug 24 '10 at 20:52

Can you access this drive from other machines?

If the answer is no - the drive is probably damaged, or it is one of the two items I have listed below.

If the answer is yes, Can you give model details and I can look in to it - it is possible the drive has "special" features which are not Vista compatible.

I have only seen this on two occasions:

  1. It was a generic USB stick and the memory was not integrated into the circuit, but was an extra module which was pushed into place, sometimes it came loose and squeezing the drive fixed it as it reconnected the parts

  2. The disk was completely (hardware) encrypted and required drivers installed in order to read from it

  • On linux, it shows the icon but it is not able to mount. It is AMKETTE 4GB Spectra Pro.
    – pineapple
    Nov 22 '09 at 9:00

Not the answer you're looking for? Browse other questions tagged or ask your own question.