1

I am working with two friends to create 3D game using Processing. Processing uses OpenGL for 3D programming. Whenever I run the program on my computer, everything works perfectly, but whenever my one friend runs it on his computer, he gets an error saying OpenGL error 1282 at bot endDraw(): invalid operation. Since the problem is isolated to a single computer, I am convinced that it has nothing to do with our code. My friend is running Windows 7 x64 on a Dell Inspiron that they got about three years a go. Just to give a comparison, I am running Windows 8.1 Pro x64 on an HP ProBook 4540s that I got last summer. We are both running the latest version of Java 8. My friend has tried updating his graphics card drivers as suggested on this page, but nothing has helped.

Graphics Card Properties for my Friend's Computer

Graphics Family Properties

Graphics Card Information

  • We need specific hardware information about the system its not working on. This sounds like the hardware does not support the OpenGL version the code is written against. – Ramhound Apr 4 '14 at 22:02
  • @Ramhound I am on my friend's computer getting screen capturess of the graphics properties as we speak. – DavidB Apr 4 '14 at 22:03
  • We just need basic information. Specifically what GPU does this person have? Only the latest Haswell products support more modern revisions of OpenGL. – Ramhound Apr 4 '14 at 22:07
  • The screenshot does not tell me which Intel HD GPU your friend has. Based on the driver version it wouldn't have supported for recent revisions of OpenGL. What version of OpenGL are you compiling against exactly? – Ramhound Apr 4 '14 at 22:21
  • @Ramhound Added more graphics card information. I do not know what version of OpenGL Processing uses. – DavidB Apr 4 '14 at 22:25
2

Your friend is using a extremely old version of the drives which does not support the version of OpenGL your trying to target. His hardware only supports OpenGL 3.1 or below so make sure your code targets that version.

The current drivers can be located HERE. The drivers I linked are of course generic. They might or might not work because your dealing with a laptop. You didn't provide specific information so I can't be certain or link to dell specific drivers. In the end if the drivers cannot be updated your friend will be unable to run the program unless the version of OpenGL your using is switch to an earlier version. Since your using Processing this means the hardware must support OpenGL 2.0 which requires device driver support. The drivers currently installed do not support OpenGL based on the error.

The new version of the OpenGL library requires drivers that support OpenGL 2.0. This allows us to keep OpenGL support for desktop and Android in sync with one another. Unfortunately this means that some older cards and drivers (particularly on Linux) will not work, and that Processing 2.0 on such machines will be limited to 2D graphics. But the OpenGL library is developed by a single person (Andres Colubri), who works on this in his free time, and he can't support two separate video libraries with radically different implementations. Keep in mind you can always use Processing 1.5.1 to continue 3D development, though it will not be updated further, and we won't be accepting bug reports for it.

Source

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.