1

I can't use apt-offline to update my package lists, which means that I will get many 404s when trying to install older versions of packages that it thinks it's downloading from the .sig file it generates. I can apt-get --simulate install or upgrade, but I can't simulate update (as in package lists), and it says "E: command line option --simulate is not understood." On my Ubuntu machine (connected to the internet) I can apt-get --simulate update just fine and it will simulate an update on any account.

4

I got this same error as well with the latest version of Ubuntu. I'm not on the machine that had these issues at the moment, but I figured out a workaround.

First, locate the python files that are used by apt-offline, if memory services I think it was /usr/lib/python2.7/distribution-files/apt_offline_core/ or something like that. There's a file I think called apt_offline_core.py and in there is a single line that executes the command "apt-get update -qq --simulate --print-uris update". I changed the line by removing the --simulate (I don't think --simulate is necessary, given that --print-uris makes apt-get not actually do anything) and also I had to remove one of the -q's. So it now read:

apt-get -q --print-uris update

This worked. Apparantly the bug is in the apt-get package, and not apt-offline itself. I am running an older installation of ubuntu with an older version of apt-offline and that installation works and the line of code with --simulate is unchanged. So the bug is in the apt system.

| improve this answer | |
2

This was fixed in 14.04 (apt-offline was bumped to 1.3.1 but -v still reports 1.3)

https://bugs.launchpad.net/ubuntu/+source/apt-offline/+bug/1323976

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.