2

I am running Fluxbux on Ubuntu Linux desktop machines and I noticed this happens at least on Ubuntu 12.04 and Ubuntu 13.04:

I installed Ubuntu, and afterwards Fluxbox and set it as window manager.

When I start nautilus this results in a messed up Fluxbox, most notably the gnome desktop background becomes my fluxbox desktop and afterwards I cannot bring up the fluxbox menu by right clicking on the desktop.

How can I run nautilus (and probably others applications) and teach them not to mess up my Fluxbox?

3

This is due to nautilus rendering the desktop. You can start nautilus without the desktop with nautilus --no-desktop but there doesn't seems to be an option to always do it that way.

Either do something like create a shell script in ~/bin named nautilus that does exec /usr/bin/nautilus --no-desktop "$@" or patch nautilus so that the --no-desktop option is always enabled.

1
  • Dan that is a great answer, I will try to avoid nautilus. – mit Apr 5 '14 at 13:17
2

Ubuntu 16.04

Execute the following command:

gsettings set org.gnome.desktop.background show-desktop-icons false

This should stop Nautilus from handling right-clicks on the desktop.

(For future reference: this was tested to work with Fluxbox and nautilus 3.14.3)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.