10

MediaTek provides Linux driver for USB Wi-Fi dongles based on MT7610U (chipset RT2860, I personally have ipTIME A1000UA). I downloaded MT7610U USB V3.0.0.2 (direct link), extracted the archive and:

$ cd ~/Downloads/mt7610u_wifi_sta_v3002_dpo_20130916
$ sudo make
$ sudo make install

Added following to /etc/modprobe.d/blacklist.conf and rebooted:

blacklist rt2800usb
blacklist rt2870sta
blacklist rt2860sta

But the LED on the dongle did not turn on, nor there is any wireless connection available in network settings.

ifconfig gave only eth0 and lo, and iwconfig gave:

ra0   Ralink STA
      Link Quality:0  Signal level:0  Noise level:0
      Rx invalid nwid:0  invalid crypt:0  invalid misc:0

And lshw -C network gave:

*-network DISABLED
   description: Wireless interface
   physical id: 1
   logical name: ra0
   capabilities: ethernet physical wireless
   configuration: broadcast=yes driver=RALINK WLAN multicast=yes wireless=Ralink STA

I also tried the following:

sudo ifup ra0
Ignoring unknown interface ra0=ra0.

However, sudo ifconfig ra0 up did the trick and consequent ifconfig is giving:

ra0   Link encap:Ethernet  HWaddr 64:e5:99:f4:42:46
      inet6 addr: fe80::66e5:99ff:fef4:4246/64 Scope:Link
      UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
      RX packets:368 errors:0 dropped:0 overruns:0 frame:0
      TX packets:115 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:1000 
      RX bytes:94523 (94.5 KB)  TX bytes:12648 (12.6 KB)

But I still do not see wireless connection option in the network settings UI and after a reboot ra0 is shown as disabled again.

Some relevant logs:

$ dmesg | grep rt28
[   19.488641] rtusb init rt2870 --->
[   19.490869] usbcore: registered new interface driver rt2870

$ lsmod 
Module                  Size  Used by
mt7650u_sta           927128  0

$ lsusb 
Bus 001 Device 003: ID 0e8d:7610 MediaTek Inc.

$ modinfo rt2800usb | grep 2870
firmware:       rt2870.bin
alias:          usb:v148Fp2870d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v8516p2870d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v07B8p2870d*dc*dsc*dp*ic*isc*ip*

/var/log/syslog:
NetworkManager[986]: <warn> /sys/devices/virtual/net/ra0: couldn't determine device driver; ignoring...
NetworkManager[986]: <warn> /sys/devices/virtual/net/ra0: couldn't determine device driver; ignoring...

I tried by removing mt7650u and mt7630u from CHIPSET list in Makefile leaving only mt7610u, i.e.:

ifeq ($(CHIPSET),)
CHIPSET = mt7610u
endif

Also tried by moving /etc/Wireless/RT2860STA to /etc/Wireless/RT2870STA (as according to dmesg that rt2870 was the driver being loaded) with no success.

Same result with both Ubuntu 12.04 64-bit (3.2.0-60-generic) and Linux Mint 16 64-bit (a friend's box). How do I install this driver?

  • Why use the RALink drivers ? have you tried with the default Ubuntu drivers ? – Lawrence Apr 7 '14 at 3:20
  • @Lawrence, what are default Ubuntu drivers? The dongle is not working out of box by just plugging it(if that's what you mean). – ozbek Apr 7 '14 at 5:46
  • 1
    Ah right. The default drivers probably aren't configured to work with that chipset then. – Lawrence Apr 7 '14 at 7:20
5

Have no real tech knowledge but I can read and search well. I have mine up now with a blue light and showing decent statistics. Not sure what to do with an active ra0 yet. Maybe someone can help me too?

ANYWAY: I downloaded mt7610u_wifi_sta_v3002_dpo_20130916 from mediatek Edited according to these pages:

I'm using kernel 3.2 crunchbang

Also added fyi-I previously had used the ndisgtk to install windows 7 drivers but that alone sure didn't help... so the above may be the only bit you need. I also added the bin files included in the 7 directory to my firmware folder.

Sorry if I am confusing. Noticed you posted yesterday and thought I would drop in a novice response.

| improve this answer | |
  • Thanks for the heads up, but still no success. However, there is a progress, now dmesg is giving: [ 18.838304] rtusb init rt2870 ---> [ 18.840562] usbcore: registered new interface driver rt2870 [ 20.581781] !!! rt28xx init fail !!! [ 21.134603] !!! rt28xx init fail !!! – ozbek Apr 7 '14 at 6:06
  • 2
    Awesome, it is working! :) Just needed one more edit: changed CHIPSET_DAT = 2860 to CHIPSET_DAT = 2870 in os/linux/config.mk (at about line 663) for mt7610u. That's was it. After that sudo make clean, sudo make, sudo make install and rebooted. Voilà! Now I can see the wireless connection in network settings. Thanks again! – ozbek Apr 7 '14 at 6:26
3

Since Kernel 4.19 there is native support for mt7610u. Fedora 30 and Ubuntu 19.04 has this kernel version. These distributions should work without any additional effort.

| improve this answer | |
  • Did you test on any of these distributions? – ozbek Apr 11 '19 at 2:27
  • 1
    I have built Kernel 4.19 on Ubuntu 18.04 and this worked fine, so should work on these distributions as well. – Fernando Mariano Apr 12 '19 at 19:16
1

The driver is still under development. It works perfectly fine. The only thing missing is the wifi power level indicator. LED is always off: https://github.com/xtknight/mt7610u-linksys-ae6000-wifi-fixes

| improve this answer | |
0

I wanted to make an update to natura's answer mainly because I bought a Cisco AE6000 a year ago and wasn't able to use the device even after initially building the /sanrath/mediatek_mt7610u_sta_driver_linux-64bit driver. With the comment from ozbek about changing the ./os/linux/config.mk CHIPSET_DAT variable to 2870, running sudo make && make install resulted in a fully working USB wireless adapter.

The steps are:

  • Download /sanrath/mediatek_mt7610u_sta_driver_linux-64bit from BitBucket
  • Change line :671 to CHIPSET_DAT = 2870
  • sudo make && make install
| improve this answer | |
0

Here is another driver, which claims to improve upon the original Mediatek driver.

https://github.com/ulli-kroll/mt7610u

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.