The Acer Aspire 5560 MS2319 I'm working on has two seemingly related problems.

Firstly, the backspace key deletes one letter then acts as a "home" key. Del also does this. Surrounding physical keys (Pause/break, Home clicked as an FN key) do not act in this manner.) Del+Control displays behaviour. Del+Alt doesn't. Control backspace displays behaviour. Alt+Backspace doesn't. Behaviour appears intermittent, but more often than not.

This action is only true for the inbuilt keyboard. With an external keyboard the mouse does not stall.

The mouse in this system is a Synaptics TouchPad.

When any key is pressed the mouse cursor stalls. For example, on the desktop, the cursor stalls briefly if a key is pressed where there's an appropriately named icon (ie: G> stall > Google chrome selected). The pointer goes into spin, then resumes.

When a key like Delete is pressed, the mouse stalls until Escape/Control/Alt is pressed.

This behaviour is true both for the internal and the external keyboard. Moving an external mouse while typing causes "Home" behaviour from any key.

Previous work:

Virus, Malware, Spyware check: nothing

Deleted keyboard device driver and mouse device driver. Rebooted. Keyboard issue solved. Deleted moused river, rebooted, keyboard issue is back.

Checked for unusual settings in keyboard / mouse. Inbuilt mouse and keyboard have a field {f0e20f09-d97a-49a9-8046-bb6e22e6bb2e)[2] which has survived uninstall/reinstalls. The contents of this field is different on the keyboard and mouse. The external mouse doesn't have this property. The external keyboard does not have this property.

Deleted mouse driver again and rebooted.

Checked: Stop Touchpad from disabling itself when I press any keys?

Downloaded ACER driver for trackpad, uninstalled current driver, rebooted.

Both behaviours exist when booted safemode.

I've not yet opened the case. Is there anything else I should try in software?

The keyboard is still displaying this behaviour. I reseated the keyboard connector and the behaviour is lessened. The first 10 minutes of use doesn't show the behaviour at all. Numlock consistently acts as both numlock and home.

Using QiPress Lite I tested what keystrokes were being sent to the system NumLock (phys) results in Numlock_On then on second stroke: Numlock_Off Home

This seems to be physical but I can't detect if it is heat, inside the keyboard, or in the keyboard/laptop connector.


Partial solution, mouse only:

1) Mouse behaviour solved by: following http://www.youtube.com/watch?v=UMvFjYpkbHc Summary: System Tray > Synaptics Pointing Device > Mouse Properties Window > Device Settings Tab > Settings… Button > Properties for Synaptics TouchPad window > Pointing item in tree > Sensitivity item in tree > PalmCheck item in tree > Set palm check to Minimum > Apply button

2) Keyboard behaviour still occurring sporadically.

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.