8

Installing the new Malwarebytes 2.0 put a shortcut on my desktop that I want to remove, but dragging it to the recycle bin shows this message:

enter image description here

I am an administrator on this computer, so normally clicking "Continue" solves the problem, but it didn't work here. Instead, I got this message.

enter image description here

How can I resolve this? I have tried using the built in super administrator account to remove it, but that does not work either.

  • does putting a password on the administrator account make any difference? – user13267 Apr 7 '14 at 0:20
  • Did you try deleting the shortcut after booting in safe mode? – and31415 Apr 7 '14 at 10:48
  • @and31415 No, actually I didn't. – DavidB Apr 7 '14 at 12:13
5

Disable self protection module in advanced settings of Malwarebytes 2.0 then you can get rid of the shortcut. Then you can reenable the self protect module if you wish. It keeps anything from altering or moving or copying any of Malwarebytes' files.

3

A simple fix is to install Unlocker, which adds an option to the right-click context menu of Windows Explorer. Right click the shortcut, select Unlocker, and select delete. If it still encounters problems deleting the file, it will attempt to delete it on next reboot. I have had this work with files that I was unable to manually delete before, but occasionally it still would not work. In that case the issue might be able to be fixed by changing the file permissions, as Tech1337 says.

3

UAC could be an issue here. Or it you didn't install the software from this account, it could be that you are not the "owner" of this software.

Try disabling UAC by going to Action Center and changing the user account control settings to never notify.

  1. Control Panel > System and Security > Action Center
  2. On the left hand corner, click Change User Account Control settings.
  3. Drag the slider to Never notify (all the way at the bottom).

enter image description here

If problem still exists try and take ownership of the application.

  1. Right click shortcut and click Properties.
  2. Click on the Security tab.
  3. Click Advanced.
  4. If the "Owner:" field says System or any other user than yourself, Press Change.
  5. Enter your username in the corresponding field as highlighted in the picture.
  6. Try deleting the application again.

enter image description here

This should work 100% of the time. If it doesn't, you may have got malicious content on your anti-malware bytes.

EDIT: This is an issue with you not being recognized as an admin. You need to confirm your account is listed in the Administrators group. You can do this by following these steps.

  1. Go to Computer Management (MMC Snap-in) - Press Windows + X and choose Computer Management.
  2. Expand Local Users and Groups then click on Groups.
  3. Double-Click on the Administrators group.
  4. Confirm your account is added to the group. If not, Add your account.

enter image description here

  • 1
    Seems a bit hasty to disable UAC because he can't delete a file from the desktop. It's much more likely that some running application still has an open file handle on the shortcut. – cmorse Apr 7 '14 at 4:27
  • @cmorse Whatever the issue is, it is not limited just to my computer. I installed the new version of Malwarebytes on my mom's computer. Before performing the reboot that the installer requests, I tried dragging the shortcut to the recycle bin, and it worked. I put it back, and after rebooting and trying to remove it again, I got the same results that my computer gives with the admin permissions problem. – DavidB Apr 7 '14 at 10:47
  • @DavidB Have you tried using Unlocker like Devon suggested? – cmorse Apr 7 '14 at 15:25
  • 1
    Disabling UAC is the first thing I do when using a computer. I don't know about your guys but the popups are annoying. IF you know how to use a computer and know what you're doing disabling it shouldn't be of any concern. It either you're not listed as an administrator under the Administrators group, or you're not an admin with your current account. Look at the edit I made to confirm you're an admin. – 10100111001 Apr 7 '14 at 15:32
1

I was able to delete Astromenda from my PC using the free Revo Uninstaller; however, the "Cut the Rope" shortcut icon on my desktop remained, although I was no longer having pop-up issues with Windows 7 IE or Google browsers.

Several security scans for the icon revealed "No Issues," as if completely hidden and invisible.

After surfing my PC (using tips from various postings on different sites), I was finally able to delete the shortcut icon.

At issue was the required Administrator Permission to delete the icon. Here's how I was able to regain control and overcome this on my system (Windows 7).

Right click the "Cut The Rope" icon on your desktop.

Click the General Tab.

Find "Location" and view exactly where the icon is embedded - this will tell you the administrator's name (e.g. System, Owner, etc.) - on my system, it was listed as "C:\Users\Owner\Desktop\Cut the Rope.url" - You may want to write down this information.

Next, go to:

My Computer

OS(C:)

Users

Owner

Desktop

Find "Cut the Rope" among the list and right click it.

Properties

Security

Click "Advanced" - located below the "Permissions for Owner" box.

Click on the exact name that was listed in the icon's location information (the one I suggested you write down).

Click on "Change Permissions."

Click on "Edit."

At this point, I saw six (6) entries: three (3) listed as "Allow" and three (3) listed as "Deny."

You will need to modify the "Deny" entries, one at a time.

Click "Allow" at the top of the box for each entry. Make sure the "Include inheritable permission from this object's parent" is NOT checked.

The "Deny" entries will disappear after you modify them to "Allow" and hit OK.

At this point, only the three (3) "Allow" entries should remain in the box.

Click OK and close the screen. You will immediately notice the desktop icon no longer present.

Restart your system...and, hopefully, you'll be back on track without any issues.

I hope this helps out. It worked for me.

Disclaimer: By no means am I a techie, so I hope I have listed the process accurately, as I am running off memory...after being up all night figuring this out (it's 6:25 a.m as of this writing).

Best of luck, everyone!

Cheers!

1

Check file permissions to see if Users have the needed permissions. I have had repeated issues with un-delete-able desktop shortcuts and when I examine the file permissions for the shortcut, I find that "Users" is not even listed. When this has been the case the following fix has worked for me without doing anything crazy to the system.

Right-click on the shortcut and select the "Security" tab. Select "Edit" under the list of Group or Usernames. Click Add. In the box labeled "Enter the object names to select," type in "users." Hit enter and it will take you back to the previous screen, where Users should now appear in the list. Click on "Users" to highlight it and then select Full Control under the Allow column. Click OK and OK again in the next screen. It should now allow you to delete the shortcut.

As far as I am aware this fix does absolutely nothing except alter the file permissions for the shortcut itself, not the program to which it points or anything else. If I'm wrong, please correct me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.