0

We have a existing network setup where we have two D-Link switches,connected to each other. IPs are manually assigned in the range of 192.168.0.x on PCs directly and unassigned ones get IP from the switch. We recently added a WiFi router which gets IP address as 192.168.0.2. It has RIP 2M enabled. It allots IP addresses in the range of 192.168.1.x. Problem here is that I can access PCs on 192.168.0.x without any issue but I can't access PCs on 192.168.1.x from those with IPs in the range of 192.168.0.x. Should I enable the static routes or something on the router?

Regards Swapnil

1

You have your wifi router connected via the WAN port to the switches. This configuration puts all wifi (and other traffic plugged into the wifi device's LAN ports) to be behind the IP address translation and on a separate subnet.

You want to plug the wifi device into the switches via one of the LAN ports. The WAN port will not be used in this configuration. You also might want to disable the DHCP server since it might conflict with the existing DHCP server on the 192.168.0 network. This way all devices will share the same subnet.

This Reference has some implementation details; it's for 2 wireless routers, but the idea is the same.

  • I'm using WAN port because I need internet services which I think won't be possible if I use LAN port or am I missing something? Forgot to mention,my switch is connected to the internet and WiFi router gets the same from the switch. – swap Apr 7 '14 at 14:42
  • What do you mean internet services? Like what? I am assuming your 192.168.0 hard-wired network had internet access before this? – Digital Chris Apr 7 '14 at 14:44
  • Yes PCs on 192.168.0.x have Internet through the switch which is connected to the modem. So switch treats router as one of the PCs on the net. But, I can access the router with its IP viz. 192.168.0.2 but not the PCs under it. – swap Apr 7 '14 at 14:46
  • Right. My answer applies then. Plug it into a LAN port so they're all on the same network segment. – Digital Chris Apr 7 '14 at 15:09
  • 1
    Got it working. It now gets internet via LAN. Manually configured devices on WiFi. Thanks for your help. :) – swap Apr 11 '14 at 17:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.