I'm working through the installation directions for Sqoop:

Sqoop server supports multiple Hadoop versions. However as Hadoop major versions are not compatible with each other, Sqoop have multiple binary artefacts - one for each supported major version of Hadoop. You need to make sure that you’re using appropriated binary artifact for your specific Hadoop version. To install Sqoop server decompress appropriate distribution artifact in location at your convenience and change your working directory to this folder.

Decompress Sqoop distribution tarball

tar -xvf sqoop--bin-hadoop.tar.gz

Move decompressed content to any location

mv sqoop--bin-hadoop.tar.gz /usr/lib/sqoop

Change working directory

cd /usr/lib/sqoop


The first step is confusing. I think "tar -xvf ..." decompresses the files and shoots them off to some location which I did not specify. When I ran the command I saw a ton of file names listed with no particular direction as to what was being done to them. E.G.

[root@sandbox lib]# tar -xvf sqoop-1.99.3-bin-hadoop200.tar.gz
...and so on

Then I ran "mv .." to move the tar file. (Not sure why this wasn't listed as step 1). Finally, I changed the directory to /sqoop. When I run ls I do not see my files listed.

What am I missing here? I'm not strong with Linux so maybe I just totally missed something.


You moved the tarball instead of the files. The files should be at the original location of the tarball.

You could tell tar where to unpack your files:

  mkdir /usr/lib/sqoop/
  tar -xvf sqoop--bin-hadoop.tar.gz -C /usr/lib/sqoop/
  • Great answer! I didn't know the directory needed an ending slash. Of note, the files extracted to a folder which contained the extracted files sqoop-1.99.3-bin-hadoop200 in my case. Also, the file extractions are listed as relative paths. Apr 7 '14 at 16:40
  • 1
    The trailing slash is mostly optional, but there are cases in which you do need to specify it. It is good practice to always use it.
    – Bruno9779
    Apr 7 '14 at 16:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.