1

I recently discovered man --html, and am quite giddy with joy at being able to navigate the docs locally in a browser at a whim.

However, it seems like certain objects, such as tables, are not properly generated. Case in point, the first table in man --html man:

enter image description here

Here is what it looks like on the console, with man man:

enter image description here

Generating it --gxditview seems to show the table fine, man -X man.

Is there something that I may be doing wrong?

EDIT: Forgot platform information, thank you @Bruno9779 and @ssmy for asking.

$ cat /etc/issue
Ubuntu 12.04.4 LTS \n \l

$ uname -a | sed "s/$HOSTNAME/***/g"
Linux *** 3.2.0-58-generic #88-Ubuntu SMP Tue Dec 3 17:37:58 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux
$ man --version
man 2.6.1
$ firefox --version
Mozilla Firefox 26.0
  • By the looks of it, the table is an image format. Could it be that your images are being blocked? Did you disable images through the browser or maybe the Adblock plus extension is blocking it? Try disabling Adblock plus and see what happens. – 10100111001 Apr 7 '14 at 16:28
  • My version of man does not have those options. Which version are you using – Bruno9779 Apr 7 '14 at 16:49
  • More details on what you are running? I don't see this problem on Ubuntu 12.04. Opens fine in Firefox or Chrome. Even with images turned off in Firefox, they are still loaded as it is a local file. – ssmy Apr 7 '14 at 17:36
  • @Tech1337: I tried disabling AdBlock everywhere and loading the file, but I still had the same results. – eacousineau Apr 7 '14 at 20:56
  • 1
    See if you can inspect the page and find the source of the image. Try navigate to the path of the image and see if the image is there or if it loads up. – 10100111001 Apr 8 '14 at 4:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.