2

Somehow my Firefox reverted to old behaviour, and now it plays all mp3 files from URL in my browser. I want it to ask for download location.

I have tried several things such as:

  • Firefox settings -> Programs -> ... no option for "save as" there. Edit: actually i see "save as" option there now, but when i select it, it still plays on the browser even after reopening firefox.
  • about:config / media.windows-media-foundation.enabled -> false
  • AppData\Roaming\Mozilla\Firefox\Profiles\n74u0loi.default\mimeTypes.rdf -> NC:saveToDisk="true"

But I cant get it to work.

Firefox version: 28.0 (newest)

Edit: yet not found the solution. still forced to right click every mp3 file...

  • I can't advise about firefox settings, but as workaround you may try FlashGot. It allows downloading all files (including .mp3s) from page in 3 clicks. – LogicDaemon Apr 27 '15 at 10:03
  • @LogicDaemon, downloading all files isnt very friendly when i only need one. Those kind of downloaders also have the problem that its very hard to find the file you want to download from the page. – Rookie Apr 28 '15 at 10:37
  • well, if you usually download few files from page, then yes, this is not applicable. – LogicDaemon Apr 28 '15 at 11:29
5

Firefox Menu => Options => Applications

Choose "Save As" for (.mp3) (audio/mpeg) and also for (.mp3) (audio/x-mpeg)

  • 1
    As i edited a while ago, that makes no difference when i selected "save as". (for some reason that option wasnt even there a while ago, maybe because i edited mimeTypes.rdf?). – Rookie Apr 7 '14 at 16:58
  • 1
    I just wonder why people upvote answers that doesnt solve the problem at all. Do they even read comments before upvoting? – Rookie Apr 8 '14 at 12:21
  • What if the specific MIME type isn't listed there? – mrt Jul 10 '14 at 14:18
  • 1
    @Rookie they upvote because it worked for them or at least they found answer useful. But only you can mark question as accepted. – LogicDaemon Apr 27 '15 at 10:00
4

Open about:config and change media.play-stand-alone to false. According to this answer on mozilla support, you should change media.windows-media-foundation.enabled back to the default value.

Edit: On older versions of Firefox media.windows-media-foundation.play-stand-alone helps.

  • Welcome to SuperUser! Note that I'm not a topicstarter. For me, there is no option media.play-stand-alone in 31.5.0, actual option name is media.windows-media-foundation.play-stand-alone. Default is true, and file plays in browser. When I set it to false, clicking on the file causes download window to appear. Shall I add media.play-stand-alone? Please edit your answer to clarify concerns. – LogicDaemon Apr 24 '15 at 21:28
  • @LogicDaemon Thanks for the input. I'm not an expert, I just found this question, and somwhere else the answer, so I thpught I put it here. I don't know the difference between media.windows-media-foundation.play-stand-alone and media.play-stand-alone, I can only assume that media.play-stand-alone is for all kinds of media, and media.windows-media-foundation.play-stand-alone is for windows media foundation files only? If media.windows-media-foundation.play-stand-alone works for you, I gues that is good as well. – Fabian H. Apr 25 '15 at 14:24
  • @LogicDaemon - If you don't have media.play-stand-alone then your not using the current version of Firefox. – Ramhound Apr 25 '15 at 14:31
1

A makeshift workaround is to mangle the address, like this:

data:text/html,<a href="http://www.example.com">bla</a>

Replacing http://www.example.com with your actual URL, of course. This results in a link being displayed where you can right click and use “Save Link As”.

  • This is not an answer for his question. Although more easy workaround is right clicking on the player or even on the link and select save as in the context menu. – NoNameProvided Apr 8 '14 at 9:41
  • It's not always possible to do that, for example with server-side redirects. – Daniel B Apr 8 '14 at 11:10
  • @NoNameProvided, yeah that works sure, but its tedious to do multiple times in row. – Rookie Apr 8 '14 at 12:20
0

If you want to disable the automatic playing of the MP3 files, so you can download instead of play, and your "about:config" does not have media.windows-media-foundation, for example if you have Linux, change

media.gstreamer.enabled

to false

  • Welcome to SuperUser. Please note that while your answer may be correct for Linux, the question was about Windows. – harrymc Jun 14 '14 at 18:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.