1

I've noticed a recent change in how Chrome for Windows handles click on links with middle (wheel) mouse button, when link's target (URL) points to the same website.

For many months (years?) clicking any link with middle mouse button, always opened t in a new tab. It acted as selecting Open link in new tab from context menu. This behaviour was permanent and happened always, no matter what target URL link had.

Recently, I noticed a change. When link's address points to the same website (anchored link) Chrome always opens it in the same tab, even if user click such link with middle mouse button (force new tab).

Does anyone knows, if above described change is permanent and if there is any way to prefent it (to switch back to "old" behaviour, where all middle-clicked links were open in a new tab)?

EDIT: Case solved (with installation of an extension proposed in an answer). For future reference and for people looking for a living example -- here is one of many (Yii Framework Class Reference):

1. Visit CDbColumn class definition.

2. Middle-click on queryScalar link at the end of third paragraph (feel free to test other).

3. Switch to opened tab and middle-click on query link in the only paragraph below properties table.

All links are internal / anchored links, all pointing to the same (own) CDbColumn page. Without "fixing" extension installed, first (queryScalar) link opens in new tab, while second (query) in the same tab.

To make things even worst, I've analysed source code of each of mentioned links, to see, if presented problem isn't caused by some error / changes in HTML code. Code for both links is the same:

<a href="/doc/api/1.1/CDbCommand#queryScalar">queryScalar</a>

<a href="/doc/api/1.1/CDbCommand#query">query</a>

So, this is cleary a bug in Chrome.

migrated from webapps.stackexchange.com Apr 8 '14 at 17:17

This question came from our site for power users of web applications.

  • 1
    What version of Chrome are you using? Can you give specific example of links that don't work? Have you tried with extensions disabled (--disable-extensions)? Everything works fine for me in Chrome 33 on all the links I tested on SuperUser. – heavyd Apr 8 '14 at 17:20
  • @heavyd: I'm using newest version of Chrome (33.0.1750.154). Are you able to use any other, if Chrome never takes care of asking you, whether you want to update, only updates itself? No, I haven't use --disable-extensions, because... I don't have any extensions installed! :] BTW: Where, in SuperUser, you see an "anchored" links, that is the one, that points to the same page? I must be missing something, but I haven't seen much of them here. – trejder Apr 9 '14 at 8:18
1

According to this thread and the bug tracker that it link's to, it seems to be a problem with the way Chrome/Webkit handle's onclick events triggered by middle click.

And believe it or not, there's actually an extension that supposedly fixes this bug (even though Google still hasn't got around to fixing it in five years of it being reported). I only tested it briefly, but it seems to work.

  • If this problem is really reported five years ago and haven't been fixed ever since, then I'm not surprised at all, that people are tired with dev team ignorance are helping themselves other ways. Thanks for a great answer and a point to an extension that does seems to do its job perfectly! – trejder Apr 9 '14 at 8:24
0

This may or may not be a bug in Chrome, but the website is definitely doing something non-standard.

Like the bug report linked to in Cybertox's answer mentions this an undefined/inconsistent behavior of the Javascript "click" event when the middle mouse button is used to click a target.

The website you mentioned in your question is using some Javascript to change the anchor target. Notice when you hover over or look at the source for the "query" link the target is #query, however if you click on the link and look at your address bar the hash is #query-detail.

You'll notice that middle-clicking anchor links on a site that does it correctly (like VirtualBox's documentation) works just fine. You may want to notify the website owner of the bug in their code.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.