3

I think I'm experiencing a wierd issue; I hope I'm not, and that I'm just somehow missing something consistently.

Here's a quick breakdown:

  • Running VirtualBox 4.3.10
  • Windows 7 Ultimate x64 (SP1) Host OS
  • Windows 7 Ultimate x64 (SP1) Guest OS

When I initially created the VM, I had configured it for 20GB, dynamically allocated. I was quickly running out of space, so I decided to expand the disk.

http://www.howtogeek.com/124622/how-to-enlarge-a-virtual-machines-disk-in-virtualbox-or-vmware/

I followed the above article using VBoxManage.exe and GParted, and was able to expand my disk from 20GB to 30GB. At each step, my progress coincided with that of the article.

I am now trying to expand the VM again, to 50GB.

So, following the linked article again, I run:

VBoxManage.exe modifyhd "G:\Users\Bracketworks\VirtualBox VMs\Windows 7\Windows 7.vdi" --resize 51200

It appears to complete with success, however, when I fire up the VM to confirm, the guest doesn't report any unallocated space (as I understand it should; 20GB in this case)

Further, if I boot into GParted it shows the same; there is no unallocated space to expand the partition.

Oddly though, the VirtualBox UI is reporting:

  • Virtual Size: 50.00 GB
  • Actual Size: 23.48 GB

The virtual size property seems correct! But I cannot verify this elsewhere (nor can I actually expand the partition to use the space)

So, my question is; why is this happening, and how can I get the VM to recognize the unallocated space and allow me to expand into it?


Addendum; I'll just keep adding pertinent details here.

Output for showhdinfo

VBoxManage.exe showhdinfo "G:\Users\Bracketworks\VirtualBox VMs\Windows 7\Windows 7.vdi"

UUID:           11fbdc84-e09c-47a1-9575-899ec00234ef
Parent UUID:    base
State:          created
Type:           normal (base)
Location:       G:\Users\Bracketworks\VirtualBox VMs\Windows 7\Windows 7.vdi
Storage format: VDI
Format variant: dynamic default
Capacity:       51200 MBytes
Size on disk:   24044 MBytes
In use by VMs:  Windows 7 (UUID: cb587799-08d8-4d8b-958f-6d5b40992550) [Logon (UUID: 19c662aa-819b-4ac5-8dc9-93a036679f57)]
Child UUIDs:    df33a561-38a5-49e1-b458-738217743cfc
| improve this question | | | | |
  • I've no idea if they would cause such a behavior, but do you have snapshots on that VM? And FYI: That article you linked is wrong, Windows 7 can expand the system partition that is currently running. So no need for GParted or a similar tool. – cremor Apr 9 '14 at 8:00
  • Yeah, most likely snapshots are the issue. I've found an identical question: superuser.com/a/476554/246852 – cremor Apr 9 '14 at 8:35
  • @cremor I had a hunch that it was the snapshots, which I do have on that VM. I'll have to give the suggestion in that answer a shot when I'm at my machine. Also, didn't realize I could expand the system partition while running :-) At least I'm aware of GParted now. – Dan Lugg Apr 9 '14 at 13:44
  • Also, sorry about the dupe; I thought I checked, but there it is on the sidebar... *sigh*. – Dan Lugg Apr 9 '14 at 13:52
0

I was having the same problem, where I resized the VDI using the command at the prompt but then Windows 8.1 would not show the extra disk space in Disk Management (despite the VirtualBox UI showing the updated size). I tried restarting and all that, but it made no difference. In my case there were actually no true snapshots. However, there was a simple Saved State file.

After reading around Online, I tried shutting down the OS so that there was no saved state, followed by running the command again at the prompt (with the exact same number for the capacity). When I started the OS again, it actually showed the added capacity. Hence, make sure that (a) there are no snapshots and (b) the OS was shut down completely to where there is no saved state.

This was using VirtualBox 5.0.0.

| improve this answer | | | | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.