So, I thought give Windows 7 a shot on my iMac 20" running Snow Leopard. Installation went well, it is running without any problems. After the installation, some very strange problems occur:

  1. When I boot into OSX, I have to wait for at least 5 minutes or longer, before I can login to my useraccount. I see the users on my screen, but when I click one of them nothing happens. After the 5 minutes, it's like the system awakes en everything I typed in the meantime appears.
  2. It takes 2 or 3 tries sometimes before i really load into OSX. Most of the time my system freezes while loading the icons in the top, or loading the software in the dock. After 2 or 3 tries I usally make it through, and I can use OSX. While freezing I only see a colored cursor.
  3. While using OSX, at unexpected moments the system can freeze, showing me just a colored cursor. Probally the same cause as problem 2. It's usally Finder or Safari that causes the system to freeze. Most of the time I have to reboot, but sometimes it works to put the iMac into sleep mode.

I thought this wouldn't be the worth the trouble, so I decided to uninstall the Bootcamp partition. But ofcourse this won't work either. When I start the Bootcamp-assistent, it states I don't have the latest firmware, although I absolutely have according to the website.

Edit: Of course, I tried to check permissions and check the disk with the installation CD and Disk Utility. I cannot check the Bootcamp partition, that one is grey, and according to Disk Utility, my Macintosh HD partition seems to be fine.

Is there a solution for this?

Edit 26-11-2010: So, still no solution. Thought I backup and format the system. No luck! Backup is also freezing.

Edit 30-11-2010: Deleted the Bootcamp position, resized it to the original format. No disk errors or permission errors. OSX is running a bit better, but all problems still occur.

Edit 21-12-2010: I am afraid this is gonna cost me a trip to the Apple Store? I was tired of the problems, so backup op important files manually, and dit a format on my harddisk, trying to re-install snow-leopard. The problems persist on the clean system. So, I did another format using the "rewrite everything with zeros" option. First time I did that the install crashed showing the "You need to restart your computer, hold down the power button" screen. Second time, it finished. Right now I am installing Snow Leopard, but almost certain that the problems are not solved, since the installation is freezing on the colored cursor I saw so many times before. Did the Apple Hardware Test, no problems found. Is this a faulty HDD or what?

Edit 23-12-2010: I managed to install Snow Leopard after a dozen tries. Are there any steps I can try before I have to turn in the iMac to a Service Center?

Edit 9-11-2011: After a long time of just leaving this problem, I started to anger me more and more, so I bought a new hard drive, and replaced it myself. The problems keep going on.. what could this possibly be now?

Just for information, the reason that I am so desperate to fix this myself, is because I can't afford to lose my computer for a few weeks, since I have no proper replacement. Also my warranty has expired a long time ago.

  • So, still no solution. Thought I backup and format the system. No luck! Backup is also freezing.
    – sv88
    Commented Nov 26, 2009 at 11:16

3 Answers 3


From the fact that a format with "rewrite everything with zeros" has crashed, it seems to me to indicate a hardware problem.

I would guess further that this is a problem with the hard drive. But it can be the disk, the cable, or even the controller on the motherboard. Under this hypothesis, some component that was anyway on the verge of failing, has collapsed because of the I/O required for the installation of Windows.

If I am right, then I am afraid that the trip to the Apple Store might be required.

  • I'm gonna go with this. I'll post the results in this thread after I they have found out what is wrong.
    – sv88
    Commented Nov 16, 2010 at 13:17

Snow leopard has an issue when it auto-mounts NTFS drives about 1/2 of the time. You can stop that issue all together by using fstab to force unmount your NTFS drive/partition on boot: just open a terminal, type:

sudo pico /etc/fstab

if there is data already in this file DO NOT overwrite it, just add a line at the bottom, and ALWAYS back up the contents before modifying it.

Now just add a line in this format:

UUID=[uuid of your NTFS drive/partition] none ntfs ro,noauto

The UUID is the unique ID associated with your ntfs partition, it can be found in disk utility, by clicking on the bootcamp drive and hitting Information. example:

UUID=AF6CC054-D314-4FB8-A77C-537BB957C3C7 none ntfs ro,noauto

Now hit ctrl + o to save the file, and restart your system... presto... no more lockups / freezes

For more information on how this works, open a terminal and type

man fstab
  • Hmm, that seems to make sense. But I already deleted the partition a few days ago (check first post), and I only have a Journaled filesystem, and a extern firewire hard disk (also journaled). Nothing changed.. :(
    – sv88
    Commented Dec 3, 2009 at 21:06
  • hmm that sounds like a deeper issue... You might be getting read errors that SMART doesn't tell you about. I would run a smartctl long check on your drive then. You would need to install macports and then the smartmontools package, but here is a link that explains how to use it: cyberciti.biz/tips/linux-find-out-if-harddisk-failing.html (instructions are for linux, but the only real difference is that OSX calls disks /dev/disk0 /dev/disk1 etc... Commented Dec 4, 2009 at 0:34
  • Taking a long time to check! By the time it should be finished the system already crashed once..
    – sv88
    Commented Dec 19, 2009 at 15:40
  • thats a when you look at the check's logs did any errors show up? also... are you disabling NTFS read with fstab? Commented Dec 21, 2009 at 8:44
  • You mean the console from OSX? Or the log from fstab? Also, check my first post for update. Should I retry your method even if a full format did not fix the problem? Or is it a deeper problem now?
    – sv88
    Commented Dec 21, 2009 at 20:30

I would do a memory test. It sounds like it could be a memory issue to me. Comment back if you do a memory test to let me know the results.

  • Could it basically be both RAM-modules if their from a bad batch? I tried removing both of them before, leaving 1 behind each time. That didn't solve the problem. I'm gonna try a advanced memory test tonight, and will let you know the results.
    – sv88
    Commented Nov 14, 2010 at 16:42
  • Well, it is very unlikely for both memory modules to be bad in a batch, but possible. Let me know how the adv. memory test turns out.
    – David
    Commented Nov 15, 2010 at 15:22
  • I let memtest run through the night, and all tests passed without problems..
    – sv88
    Commented Nov 16, 2010 at 8:26
  • Sorry I don't know then. Everyone has suggested all other possibilities (I think).
    – David
    Commented Nov 16, 2010 at 13:12
  • Thanks anyway. This was the last option I could possbily fix myself. :)
    – sv88
    Commented Nov 16, 2010 at 13:16

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .