For some reasons I'm running into SSL problems since a few days. When trying to clone a git repository for example I receive the following error message:

fatal: unable to access 'https://someuser@bitbucket.org/somerepo.git/': SSL certificate problem: Invalid certificate chain

I was able to solve this issue by setting the following configuration option:

git config --global http.sslVerify false;

But when I try to access github.com or bitbucket.org through chrome I get the following:

HSTS failure

certification failure certification failure

Unfortunately it's in german but in short it says that the connection is affected by something. The failure type is HSTS failure. The second screen says that the certificate was signed by a unreliable deliverer.

I'm using Chrome (34.0.1847.116) on a Mac (OS X 10.9.2 (13C64)).

Any suggestions what could cause this issue or how to solve it?

  • Pretty sure this is Heartbleed – w00t Apr 10 '14 at 6:55
  • @w00t But as far as I understand the Heartbleed bug there ought to be something wrong on the github server. And these seem to be fine: filippo.io/Heartbleed/#github.com Or am I wrong? – damian Apr 10 '14 at 8:23
  • Click on the lock next to the https:// and then you can inspect the certificate chain and see which cert is invalid. – w00t Apr 10 '14 at 8:24
  • @w00t Updated my question. It's quite strange that the Mac Keychain Access doesn't show any invalid certificates... Also there is no issue when using any other browser (like Safari). – damian Apr 10 '14 at 8:38
  • 1
    Click on the first cert and see why it's not trusted. It's still trusted on my phone... – w00t Apr 10 '14 at 8:44

i've got the same problem since weeks (!), exactly same setup (chrome / mac os - newest versions), also from germany. anybody an idea?

workaround: use safari or firefox.

seems to be a chrome specific problem.

- update -

here is the solution:


  • delete false certificates
  • will be correctly recreated by system on reboot
  • 1
    Removing the certificates solved it for me... Danke! – damian Apr 16 '14 at 7:54
  • I tried this and it didn't work for me. Or rather, I deleted a bunch of certs that were expired and it is still not working. How do I add the more updated version of the ones I removed? Once I go to the site, should it auto download the correct certificate? If that is the case, when I go to Heroku it is still giving me the error. – marcamillion Sep 3 '14 at 6:43

This other answer helped me: https://superuser.com/a/788547.

It's Mac OS X related, and it helps solving a problem that affects chrome in a similar way (with Github) because of a certificate that expired on July 26th 2014.

The steps that worked for me:

  1. Open Keychain (Applications / Utilities / Keychain)
  2. Go to Presentation -> Display expired certificates
  3. Find the "DigiCert High Assurance EV Root CA" certificate
  4. Close Chrome
  5. Download back this certificate from : https://www.digicert.com/digicert-root-certificates.htm
  6. Drag it to your "Session" keychain
  7. Restart Chrome
  8. Go to github, should be solved!

I've been having similar issues.

Try synchronizing your system clock with an internet time server. SSL connections check the date and time of the system so doing this fixed it for me.

  • This was my problem as well--you can tell if this is "your" problem by [ironically] browsing to the same site using firefox, if it shows a message like "The certificate will not be valid until 07/30/2014 05:55 AM. The current time is 07/17/2014 07:54 PM." then your time is out of date. – rogerdpack Aug 7 '14 at 22:45

This is what worked for me (mac, not able to open github):

  1. Open Keychain
  2. Select "View" -> "Show Expired Certificates"
  3. In the search box, type "Digi". This should be enough to show any/all DigiCert certificates.
  4. Delete any certificates that have a red "X" icon (these are expired).
  5. Navigate to / reload GitHub. You should be allowed access.

Worth noting, I did not need a restart of Chrome or the OS.


The certificate of BitBucked and GitHub was recently revoked but they didn't restart their servers at the moment you were trying to connect. Just try again right now. It should be fine.


None of the above helped me. I tried this

export GIT_SSL_NO_VERIFY=true

Via -> http://www.uwosh.edu/ploneprojects/docs/how-tos/how-to-fix-a-git-ssl3-get-server-certificate-error

  • and it works?.. – Francisco Tapia May 29 '15 at 20:44
  • It does, and we have to set it false again, after the clone is completed. – Vaibhav Jain May 29 '15 at 21:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.