0

Every time I open my Windows after a while the USB ports stop working, and while I tried using the Device Manager to uninstall USB then reboot, the problem is still not solved.

  1. I tried to uninstall everything in the universal serial bus category.
  2. I update every USB port I have.
  3. I unmarked “allow the computer to turn off this device” in power management.

The USB ports work properly for a while after a reboot, but then they stop working again.

  • How many USB devices do you have connected to a single port – Ramhound Apr 9 '14 at 16:47
  • i only connect the mouse – muhanad Apr 9 '14 at 16:48
  • 1
    If a single device stops working this indicates a hardware failure on the motherboard itself dealing with the controller. Replacement is the only solution for that problem – Ramhound Apr 9 '14 at 16:51
  • i already replaced usb ports from 2 weeks ago and they are new, and all usb ports stop working not just one – muhanad Apr 9 '14 at 16:54
  • i think that its a system problem because usb ports work after reboot but not for a long time, work for a half hour only – muhanad Apr 9 '14 at 16:58
0

I had this issue once before. What solved it for me was going to the Motherboard manufacturers website and then downloading updated drivers for the USB controller on my motherboard.

If this doesn't work, check the BIOS and try disabling the Legacy USB mode.

  • i have toshiba satellite laptop c660, inel core i3, and how i download updates ? – muhanad Apr 9 '14 at 17:16
  • 1
    You should be able to find these on their driver site... – Ben Lavender Apr 9 '14 at 17:49
  • 1
    support.toshiba.com - Go to this site and enter your model number. You should be able to find drivers there, as Ben mentioned. – byachna Apr 9 '14 at 17:51
  • thank you but after i uodated the device no usb port are working – muhanad Apr 9 '14 at 23:06
  • @muhanad if you updated the BIOS (paricularly if you find USB suddenly stops or in your case, stops completely while it was partially funny before then you shoudl know that )what can happen is USB can be disabled, so you should look for any options in the BIOS about USB to enable it. I'm not saying that'll fix it, but it's possible that whatever problem you had before, updating the BIOS(whether it also helped or not), also might have disabled USB. In case of that event, doing what I suggest there would help at least somewhat. It's possible. I have seen it happen after a BIOS reset. – barlop Apr 11 '14 at 9:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.