2

I have a Cisco SPA122 ATA Router in Bridge mode where I connect my analog phone. Turns out that usually on incoming calls, I don't have any issues: connection goes smoothly, the caller hears me perfectly and so do I.

The issue is that sometimes (mostly, though), when I'm the caller, the callee hears me with so many interruptions that they cannot understand anything and we have to hang up. Other times it works just well.

I've tried really anything, so if someone has a tip on what could be the issue, I'd really appreciate any fresh idea. Here are some facts of what have I tried and results:

  • With a softphone, everything works smoothly even on outgoing calls, always (using GSM codec).
  • I've tried both with a Linksys ATA PAP2 device and a Cisco SPA122 ATA Router, same happens with both.
  • I've tried changing the RJ-45 cable that connects the router and the ATA device, no result.
  • I've tried switching to another VoIP provider, same happens.
  • Usually both the analog phone, the VoIP ATA device, the router and a SmartTV are very close together. I've tried putting the ATA device far from them, same result.
  • Of course I've tried switching between different codecs: G711u, G711a, G729... same result.
  • Ports 5060/UDP and 10000-30000/UDP are open in my router device.
  • I've even tried activating QoS to priorize voice calls, no effect.

The only thing left I haven't tried is replacing the router device, but before doing so I prefer to place that question to know any additional possible issues.

I've also considered this could have something to do with WiFi interferences, or even some other devices interfering together, but I'm not quite sure if this even makes sense. Any other ideas?

Thanks.

---- EDIT 11/04/2014 ----

I've made a "drastic" experiment: I've disabled WiFi in my router's config and surprise, outgoing calls work perfectly! Even with P2P programs working hard and other downloads.

I've been trying this config for 2 days and it hasn't failed at anytime. So what's the logic of this? Might WiFi interfere with the ATA device even when this latter doesn't use WiFi but a RJ-45 connection to the router? Or might it be that the WiFi signal is interfering with my neighbor's and making the signal that weak in my router that it makes fail the VoIP call?

---- EDIT 12/04/2014 ----

I've read the whole @harrymc's suggested article, and though my cable-modem is not the same brand, I've tuned up several parameters (for instance, deactivating b+g WiFi mode and leaving just n). Also, the QoS seems pretty much complex in the mine (Tp-Link TD-W8951-ND), I already had a configuration to priorize VoIP but I've also included one to priorize RTP.

Unafortunately, I can't find the WMM option in this router (at least not with this name or any related). But thanks to that link, I've also discovered an additional parameter, ATM QoS, which was set to UBR which seems to not be the recommended for protocols like VoIP. So I changes it to be CBR, will try this way to see how it works.

  • Could be that the WiFi is taking priority over ethernet connections. – AWippler Apr 11 '14 at 23:15
  • @AWippler How could I check that? Is there some known parameter that handles that? Even in that case, priorizing VoIP via QoS should avoid it... – nKn Apr 11 '14 at 23:24
  • My Verizon router has WMM (en.wikipedia.org/wiki/Wireless_Multimedia_Extensions) and no matter the setting, it always seems to be enabled. If disabling WiFi on your router does the trick, it must stem from that. – AWippler Apr 11 '14 at 23:29
  • See this article for router optimizations. I would look especially at the supported wifi protocols and turn off the older or unused ones among b/g/n and 2Ghz/5Ghz. Try also to change the wifi channel. – harrymc Apr 12 '14 at 9:48
  • @harrymc Thanks, I've updated my question with some additional data related to the article you've suggested. I hope these changes will help! – nKn Apr 12 '14 at 14:51
1
+50

As there are many settings that could influence the quality of VoIP, I recommend comparing all settings with those listed in the article :
How to configure your router for blazing speeds.

You should especially disable all unnecessary WiFi modes and protocols, for example "b+g WiFi mode" if you only have "n" devices, or 5GHz if you only have 2.4 GHz devices.

  • For users with the same issues: I finally managed to have a stable outgoing calls by changing 3 things: Disabled b+g WiFi mode, added a QoS configuration also for the RTP protocol and set ATM QoS from being UBR to be CBR. With this changes my outgoing calls started to be consistent. – nKn Apr 16 '14 at 10:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.