4

Since I updated to Windows 8.1 (Enterprise) I have a sporadic issue with RDP connections. They're very slow. So it looks like the the machine runs at 100% with a high ping. But it's not.

The host itself is irrelevant in this case, whether it's Server 2012 or Server 2003. Having a look in the task manager, no process runs at 100% CPU nor consumes all the memory.

To workaround this issue, I'm running a Windows 7 VM and connect via RDP through this machine.

The problem is, I can't really reproduce the problem. My colleague has this issue in the office and at the customer's network. I just had it while being at two different customers.

We use TrendMicro OfficeScan which I thought might be the problem, but after disabling it, the problem persists.

7
  • So, this issue still persists. I disabled TrendMicro, played around with all the tips regarding auto-network-configuration which a lot of people mentioned on forums etc. -> nothing happened. – sascha Jun 23 '14 at 6:10
  • 1
    Try to Run as Administrator in Command Prompt : netsh interface tcp set global autotuning=disabled. You might need to do that on both client and server. You could also in the RDP Options, "Experience" tab, adjust the Performances settings. Have you also fully patched Windows 8.1 including optional Windows Updates (except Bing)? – harrymc Jun 23 '14 at 9:12
  • That's what I was talking about, when I wrote "auto-network-configuration". Doing this on a server is not really an option, since the issue occurs with a few customer's servers. Yes, the system is up to date. – sascha Jun 23 '14 at 19:11
  • 1
    (1) There are several solutions mentions in this thread - see if any of them helps. (2) You could also try to install the Windows 7 network adapter driver in Windows 8 (rollback if problem). (3) Try disabling/enabling Desktop Composition and Visual Styles and also Windows standard/basic themes. (4) Ensure that local and remote desktop color depths are the same. Note: You might have differing results for servers 2012 and 2003. – harrymc Jun 24 '14 at 7:29
  • 1
    In my opinion, RDP 7.1 in Windows 7 was the last decent RDP version, but I don't think it's an option in Windows 8.1. I never tried it, but you could copy mstsc.exe and mstscax.dll from Windows 7 to system32 on Windows 8.1, then do regsvr32 C:\Windows\System32\mstscax.dll. Take backups. – harrymc Jun 24 '14 at 7:44
3
+50

Things to try :

  1. Fully patch Windows 8.1 including optional Windows Updates (except Bing).

  2. Disable TCP/IP auto-tuning by entering in Command Prompt that is Run as Administrator:
    netsh interface tcp set global autotuning=disabled

  3. In the RDP Options, Experience tab, adjust the Performances settings.

  4. Turn off Scalable Networking Pack with this registry hack :
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters]
    EnableTCPChimney=dword:00000000
    EnableTCPA=dword:00000000
    EnableRSS=dword:00000000
    Export the old settings of this key as backup.

  5. Try disabling/enabling Desktop Composition, Visual Styles and Windows Standard/Basic themes. This might work differently with Server 2003 and 2012.

  6. Ensure that local and remote desktop color depths are the same.

  7. Lastly, it is my opinion that RDP 7.1 in Windows 7 was the last decent RDP version, but it's not an option in Windows 8.1. I never did it, but you could try to copy mstsc.exe and mstscax.dll from system32 in Windows 7 to Windows 8.1, then do :
    regsvr32 C:\Windows\System32\mstscax.dll.
    Take backups and create at least a system restore point before starting.

1
  • Sorry for that pretty late answer. I was at my customer yesterday. Nothing helped unfortunately. I replaced the .exe + .dll but it didn't start. Instead it prompted an error message telling me "can't find C:\windows\system32\<lang_name>\mstc.exe.mui". Since my windows is set to German and I copied the Binary from another German Windwos 7, I checked the "de" folder which contains the .exe.mui. Also copied the same file from Win7, to see, whether it fixes the issue: unfortunately not. Even copying it to en-US didn't help. I guess, I have to file a ticket... – sascha Jul 16 '14 at 9:26
1

I've got the same issue too - unloading the Trend Micro OfficeScan on the CLIENT did indeed solve the issue. Now I'm stuck at how to allow RDP connections on 3389 and mstsc in my environment

-1

I have the same problem and unloading Trend OfficeScan resolved the issue. I will add an exception in the admin console to exclude RDP from being scanned in real time.

2
  • On the server or the client? Firewall enabled in the OfficeScan? Imho, that's not really an option, since malicious software could use it to bypass the firewall. – sascha May 22 '14 at 18:36
  • 1
    in actually professional environments, there is little need for AV-solutions. Maybe on all the desktops but thats it for the most part. If you ACTUALLY need AV on servers ... well ... you did something horribly, horribly wrong in your company – specializt Aug 29 '14 at 20:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.