4

I recently purchased a new laptop. The language was initially set to UK English, but I am in South Africa, and so it should be South African English.

Anyways, I changed it accordingly, and also changed Opera. However, every time I do a search from the address bar, it still takes me to google.co.uk, which is giving me irrelevant results.

I have had a look at default_partner_content.json, but none if it helps me to get Opera to pick up the correct Google entry in the list.

I don't want to change the google_uk setting to google.co.za as that would be an impractical hack.

I want Opera to simply pick up that it is supposed to use the South African version.

Any ideas as to how I can do that?

0

For Opera Presto (older, 12.x or earlier):

  1. Go to your preferences (Ctrl+F12).
  2. Go to the "Search" tab.
  3. Select "Google".
  4. Click "Edit...".
  5. Expand "Details >>".
  6. Edit the "Address" field to replace "google.co.uk" with your preferred Google site. (You should be able to leave the rest of that field alone, the parameters don't have to change.)
  7. Test it by typing "g [search term]" in the address bar, it should now take you to your preferred site.

For Opera Blink (newer, currently 20):

  1. Shut down Opera while you do this next bit.
  2. Either find and edit the default file search.ini (typically in C:\Program Files\Opera\defaults\ under Windows), or use the one from the language folder in C:\Program Files\Opera\locale\ - if there isn't one, you should be able to add one (sorry, not sure what the code for South African English is, maybe en-ZA?) and add the files you want to override in there, i.e. in your case you could copy the default search.ini in your new language folder and edit that file.
  3. Fire up Opera again.
  4. Set your preferred language in Settings > Languages.

Opera should pick up its updated search settings from there (not sure if you need to restart it again after setting the language).

  • Surely that's for the older Opera? I am using Opera 20. The search engine manager does not have an edit button. – Mike Rockétt Apr 11 '14 at 5:15
  • @MikeAnthony: whoops, my bad, I assumed you meant the old one. Updated the answer with instructions for Opera 20 (different from how it used to work in Opera 19, so I'm not sure whether it might change again in the next version...). – Amos M. Carpenter Apr 11 '14 at 13:47
  • My folder structure for Opera is this: C:\Program Files (x86)\Opera\20.0.1387.91_0. In there is a resources folder and a localization folder, none of which contain a search.ini file. I also see that the en-ZA.pak file is missing from the localozation folder. I think I should uninstall it (keeping settings, etc.) and install it again, now that the laptop's language is set correctly. I also think that I should open up a support ticket (not sure where though), as Opera (Blink) should automatically pick up on these things... Don't you think? – Mike Rockétt Apr 11 '14 at 15:16
  • Okay, have tried that, and it doesn't work. I think it has something to do with this Windows 8.1 installation I'm using. It still offers the UK keyboard layout, even though the default is set to ZA'. All the language settings I can find are set to South African English. (It's quite strange though - Chrome Firefox and IE all use google.co.za`....) – Mike Rockétt Apr 11 '14 at 15:26
  • Have you tried searching for the file "search.ini", or for the text "[Search Engine 1]" within your Opera folder? Sorry, I use Opera 12.x and 20 on Windows 7, and Opera 12 on Linux, both with en-AU in Australian English (my default search engine is google.com.au). No experience with Win 8 (like Vista, I'm skipping that one) or with South African settings, wish I could help more. – Amos M. Carpenter Apr 12 '14 at 7:03
0

Go to up on the left Menu > Help > About Opera.

Look for the path "Profile", should be something like this or whatever place you installed Opera:

C:\Users\[user-name]\AppData\Roaming\Opera Software\Opera Stable

Important: Make sure Opera is closed.

Find on this folder a file called "Local State", open it with a text editor.

Locate the values app_locale and location and set countries to "ZA". Alternatively, use ctrl-R to find all "UK" values and replace for "ZA".

Save it and open Opera.

-1

In the latest version of Opera (Opera 48.0) there is an option in:

Settings > Languages > Select user interface language (requires Opera restart)

You can change there to English (South Africa).

  • 1
    Welcome to Super User! The asker stated that they had already changed Opera's language. The problem was specifically about which Google site Opera went to on search. Please read the question thoroughly before you answer in the future. – Duncan X Simpson Oct 29 '17 at 2:29
  • Okay, I am sorry for not reading it full. I had a similar problem and I tried above method and it worked. Now opera always searches with google.co.in. Updating the opera resolved the issue. – Dattaprasad Oct 30 '17 at 3:51

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.