22

So I have a small router I'm connected to through an ethernet cable, and I'm having multiple devices connecting to that router through wifi, so they can view my computer screen. Screen sharing on Windows 7. At the same time I would like to use my wifi adapter to connect to a different router which is connected to the internet. So far I can't do them simultaneously.

-First I just tried simply connecting to the wifi and plugging in the cable, but windows gave preference to the ethernet I presumed because the screen sharing was working but I couldn't get to the internet.

-Second I tried tweaking the preference order of adapters in Advanced settings in the Network/Sharing Center. That didn't work.

-Third I tried manually tweaking the metrics in the advanced properties for each adapter to give connection preference to wifi. This half works. I can start screen sharing and that works, and I can connect to the internet wifi network, but when I try to access it (ex. open google chrome), my screen sharing connection is killed. And this is vice versa if I got to the internet first.

Thoughts?

  • If you have the Microsoft Virtual WiFi Miniport Adapter installed, you should be able to use that to create a separate network connection. I think it is there as a developer tool but, if you have the know how, I think you'll be able to use it to create an independent network connection. There's more info at the following link: helpdeskgeek.com/windows-7/… – P Fitz Apr 10 '14 at 20:37
  • Why would I need to use the virtual adapter when I have an open wifi adapter? Besides, after testing it seems the virtual adapter can't even connect to a network, I can only create hosted networks with it.. – user3112658 Apr 11 '14 at 19:20
32

The following is a step by step process as to how you can use wireless internet without taking out your ethernet cable out.

  1. Open Network and Sharing Centre.
  2. Go to change Adapter Settings.
  3. Goto properties of Local Area Network.
  4. Click on Internet Protocol version 4 and go to it's properties.
  5. Click on Advanced
  6. You will see a block checked there by the name of "Automatic Metric".
  7. Uncheck it and then enter 2 in that section.
  8. Now, Do the same for the wireless network but enter 1.

Save the setting and you'll be able to use wifi even when your ethernet cable is connected to the LAN.

  • 1
    That's helpful but would you also give an explanation that would help even more – Ahmed Jul 15 '16 at 16:51
  • 2
    This worked for me. "Automatic metric" works by prioritizing the connection with the highest link speed. Manaully changing the setting means you can specify which connection you want to give priority to. support.microsoft.com/en-us/help/299540/… – user2924019 Apr 10 '17 at 10:20
  • 1
    On Mac OS, the same thing is accomplished in SysPref > Network > [Gear icon] > Set Service Order... and setting Wifi to top priority. – Demis Oct 10 '17 at 18:38
4

Figured it out, I needed to set the ethernet LAN IP of my machine to static and remove the default gateway.

  • I am having the same problem. Can you please explain to me how to do this? I'm not to experienced with network settings. Thanks in advance. – Jonny Sep 1 '14 at 16:27
3

Using a static IP and removing the default gateway worked for me.

Before doing anything, run a command prompt and type in IPConfig /all. Note the DNS server address, and whether you're using DHCP or not.

Go to Network and Internet settings in Windows, then Change Adapter settings.

Select the wired connection, then edit its properties. Select Internet Protocol Version 4 (TCP/IPv4) and edit the properties. Select Use the following IP address and type in a static address. This is probably assigned to you by an administrator. Leave the Default gateway blank. A subnet mask that will usually work is 255.255.0.0. You also need the IP of your DNS server from above, if applicable.

1

I had a bit different case:

My LAN network is used as a infraned VPN and also as the Cisco and Email internet with proxy settings.

If i set the metric 1 to LAN and metric 2 to Wifi, wifi don't works.

If i set the metric 2 to LAN and metric 1 to wifi, Outlook and Cisco dont' works but intranet do.

If I try any configuration remapping de gatways and DNS with IP static anithing works in LAN because i'm on a subdomain DNS without acces or Knowledge of it's IP.

So finnally I've ended up setting Wifi to metric 2, LAN to metric 1 (All dhcp enabled and ip dinamic all by default just changed the metric) Then i download virtualbox and use the Tiny W7 iso of 800mb. I say to virtualbox to use Wifi network driver to the virtual machine and uala free proxy internet conection.

Hope it helps somewone.

0

Well same problem with me and only thing was that WiFi had same local IP to connect! I mean they were: LAN (cable conected) router IP: 192.168.1.1
WiFi router IP:.................192.168.1.1!

so both give same IP group for all network devices, 192.168.1.x

So i guess Win7 got confused every time you are connected simultaneously to both networks no matter what priority you give to them in advanced settings!

so I just thought to try to use different IP groups like:

LAN: 192.168.1.1 WiFi: 192.168.2.1 and now all works just fine together! :) Meaning, windows can make now the difference betweek the 2 networks, which is not possible only by name difference!

Good luck!

0

I am on windows 10. I right clicked on the network icon, the chose 'change adapter options' Then, right clicked on the ethernet connection to select its properties. I then unticked "Internet Protocol Version 4 (TCP/IPv4)...pressed okay and voila. i can browse with my next router option. Seems after this my locally connected devices couldn't connect so i just re-enabled TCP/IPv4. Still connected 😉

protected by Community Sep 26 at 13:57

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.