39

I have windows 8.1 and its tied to my Microsoft login. I only vaguely remember setting this option up during the installation of windows. When I try to use these credentials to connect to my network share I cannot login.

E.G. \\computerName\c$

It will not accept my credentials. When I run whoami at the command line I see a different account. I don't recall ever setting up this other account.

whoami = domain\me (password unknown if I ever even set one up...)
Windows Login = me@email.com (password known, does not work with RDP)

What do I need to do in order to login to the network share?

4
  • Is the "domain" listed your computer name? Have the admin shares been enabled? What does the admin share permissions/access have to do with you logging onto remote desktop? Apr 11 '14 at 2:43
  • @techie007 Yes. Yes. Type-o, updated. Apr 11 '14 at 12:35
  • have you tried just the user part of your email and your password? This is what works for RDP at least. i.e. I log onto Win using my live account myuser@domain.co.uk and password and when I RDP to that machine I use myuser and password to log in... myuser@domain.co.uk is configured as an administrator
    – Shevek
    Apr 11 '14 at 13:35
  • 1
    @Shevek I just tried. Still no go. Apr 11 '14 at 14:31

12 Answers 12

38

You must use MicrosoftAccount\me@email.com (this MicrosoftAccount prefix is important) as username. Now enter your Microsoft account password into the password box.

19
  • 10
    This does not work either...
    – Matze
    Sep 24 '15 at 6:21
  • 3
    @Matze I tried to connect from Windows 7 to Windows 8.1U1 with only me@email.com as the username. It worked. I tried it for both file sharing and RDP. (Of course, I had to enable RDP and add me@email.com to the list of allowed users. But it worked.)
    – user477799
    Jul 31 '16 at 8:02
  • 5
    Windows 10 on both side. This worked for me. Oct 24 '16 at 9:26
  • 2
    This doesn't work for me. Both my desktop and laptop use same Microsoft account, and only from laptop to desktop can administrative shares be accessed. When trying from desktop to laptop I get challenged and the explicit declaration as MicrosoftAccount\me@domain.com keeps failing.
    – icelava
    Aug 27 '18 at 19:17
  • 2
    Turns out a custom registry key needs to be inserted in the destination computer. social.technet.microsoft.com/Forums/windows/en-US/…
    – icelava
    Sep 7 '18 at 10:20
19

Try disabling PIN login for the Microsoft Account (Settings > Accounts > Sign in options > PIN). Windows rejected my credentials until I removed the PIN, then I could sign in just using my email address.

3
  • 3
    4 years later... Thanks!
    – sdive
    Apr 27 '20 at 19:57
  • This worked. How stupid is that! Apr 19 at 8:13
  • I wish there were some way to keep pin login and still connect to samba :(
    – Almo
    May 1 at 15:54
8

Figured it out. I was able to access a network share using my Microsoft account. This is the format:

  • Username: email address tied to your account
  • Password: password that you use to login to your Microsoft account online. Not the PIN
2
  • 2
    This is the same answer already given and accepted and does not add anything. Please refrain from posting when you are not actually adding anything to the discussion. Jan 21 '17 at 0:31
  • 4
    @music2myear no the top answer specifically says to add "MicrosoftAccount\" to the beginning, which didn't work for me. I removed it per this answer and it worked.
    – Ben Baron
    Feb 28 '19 at 0:58
5

I created a local "dummy" account with admin privileges and use it only as a login for sharing.

3

If you used Microsoft Authenticato‪r when you log in to Microsoft Account and use PIN to unlock your PC, switching to local account and logging in to Microsoft Account again using your password may fix the problem. You can just use the password and ID of Microsoft Account for SMB.

1
  • This worked for me when no other answers did - I believe the two-factor authentication plays a role in the problem. Aug 28 at 17:41
1

I had a similar problem, but was not even asked for my credentials before being denied access. It took me a while to figure this out, so here's what I had to do:

  • I previously tried home groups. Didn't like it, deactivated it.
  • I added the Microsoft Account user and logged in as that as well.
  • ... however, that didn't yet work: the home group left some HomeUser group and credentials scattered in my system. I had to remove the HomeUser group and Credentials and (maybe after a reboot?) it finally worked.
1
  • Deleting HomeGroup and HomeGroupUser from local accounts as well as removing them from credential manager then restarting fixed this for me! Thanks! May 31 '19 at 7:41
0

I manage to overcome this by mapping from command line. Ex.: net use s: \tower\movies

Hope it helps

0

Don't have enough reputation to comment, but the answer by @Steve Parker worked great:

  • Create a local user account
  • Add it to the root folders you want to share (like my Users\username account in this case)
  • Add the local user account's credentials into your SMB client (in my case ES file explorer)
0

In my case the problem was the User must change password at next logon setting on the user account, which apparently gets checked by Windows automatically when you convert a local account to a Microsoft account.

To revert this:

  1. Go to Computer Management > Local Users and Groups > Users.
  2. Find your user account and open its Properties.
  3. Uncheck User must change password at next logon.
  4. Check Password never expires. <-- This is important, otherwise the unchecking above doesn't stick.
0

Had the same login problem with my Windows 10 desktop and came across this page. After digging around, I found a solution that works on Windows 10 Pro 21H1. I can log in from a Windows 10 computer, my QNAP NAS, and my Macbook Pro.

  1. Login name is your Microsoft Account email address user@email.com.
  2. Login password is your Microsoft Account password.

If the above does not work for you. Check the following:

  1. Go to Settings -> Accounts -> Sign-in options, ensure Require Windows Hello sign-in for Microsoft accounts is turned off.
  2. Once it is turned off, make sure Password is enabled in the Manage how you sign in to your device section on the same setting page. You may need to close the Settings page after turning the Require Windows Hello sign-in for Microsoft accounts option off.
-1

Only thing below that worked for me after have tried all solutions in here.

From Gautam.75801 on social.technet.microsoft.com :


I got the Access is denied issue solved when i tried to access a Netowrk share on another computer

ex \\192.168.1.0\c$\

It seemed to be a UAC issue. The below Link helped.

https://support.microsoft.com/en-gb/kb/951016

We will need to add a new DWORD

Click Start, click Run, type regedit, and then press ENTER.

Locate and then click the following registry subkey:HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System

If the LocalAccountTokenFilterPolicy registry entry does not exist, follow these steps: On the Edit menu, point to New, and then click DWORD Value.

Type LocalAccountTokenFilterPolicy, and then press ENTER.

Right-click LocalAccountTokenFilterPolicy, and then click Modify.

In the Value data box, type 1, and then click OK.

Exit Registry Editor.

3
-1

I just found a better solution. Go to your "C:\Users" folder and record the name of your personal folder. Use the name of your personal folder as account name. i.e. if your ms account is Tom.ABC@abc.com, then your personal folder might be called "tom", and you should be able to access your shared folder with account name "tom" and your MS account password.

Not the answer you're looking for? Browse other questions tagged or ask your own question.