I have install "libc6_2.17-0ubuntu5.1_amd64.deb" on my ubuntu server 12.04. The orginal libc6 on system is 2.15. After install the package, I check it by:
ldd (Ubuntu EGLIBC 2.15-0ubuntu10.5) 2.15
not change. Then I found I can not install anything which depends on libc6 by apt-get, it will reports:
The following packages have unmet dependencies: libc-dev-bin : Depends: libc6 (< 2.16) but 2.17-0ubuntu5.1 is to be installed libc6-dev : Depends: libc6 (= 2.15-0ubuntu10.5) but 2.17-0ubuntu5.1 is to be installed libnih1 : PreDepends: libc6 (< 2.16) but 2.17-0ubuntu5.1 is to be installed
So I try to uninstall the debian package, first I check:
dpkg -l | grep libc6 ii libc6 2.17-0ubuntu5.1 Embedded GNU C Library: Shared libraries ii libc6-dev 2.15-0ubuntu10.5 Embedded GNU C Library: Development Libraries and Header Files
dpkg -r libc6
It prints a alot of packages which depends on libc6 and tell me:
dpkg: error processing libc6 (--remove): dependency problems - not removing Errors were encountered while processing: libc6
It seems it doesn't know there are 2 version libc6 on system.
libc6 deinstall libc6-dev install
How should I do?