Here's an interesting oddity:

  • My work computer comes with a corporate disk image preloaded, and it is preconfigured with the German "QWERTZ" keyboard layout.

  • Using the control panel, I added my preferred QWERTY layout so I could type without going nuts over the swapped Y and Z keys (and many of the special characters like ' * ^ # that I use a lot).

  • Windows has never been good at handling multiple keyboard layouts and it kept switching back to German. So I removed the German keyboard altogether.

  • PROBLEM: My computer still switches itself back to German every now and then, and there's no way to get away from that again. I see the language selector (see screenshot) and I can choose the non-German item, but as soon as I click inside another window, the indicator jumps back to German. Only a reboot helps... for a while.

  • I've tried installing the German language and then removing it again, but it still remained. I also tried installing the German language with several layouts including US English, and then the list contained three languages: English was listed as a language even though it was only installed as a layout. Rebooted, then uninstalled the German and all its layouts again.
    --> Now I have Danish + English instead of Danish + German... ?! Windows is still broken but in a better way because at least I got rid of the swapped Y & Z keys.

Screenshot: The indicator shows that the German keyboard is active -- but it's not even installed!!?! What is this sorcery? How can I get rid of that German layout?

wtf? enter image description here

  • The layout seems to be arising from the language bar - have you checked that tab? – Sathyajith Bhat Apr 11 '14 at 16:05
  • @Sathya I added another screenshot -- nothing special there, as you can see. – Torben Gundtofte-Bruun Apr 11 '14 at 16:10
  • 2
    Could you make a screenshot for each of the following registry keys? HKEY_CURRENT_USER\Keyboard Layout\Preload ; HKEY_CURRENT_USER\Software\Microsoft\CTF\Assemblies ; HKEY_CURRENT_USER\Software\Microsoft\CTF\SortOrder\AssemblyItem ; HKEY_CURRENT_USER\Software\Microsoft\CTF\SortOrder\Language – and31415 Apr 13 '14 at 10:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.