I recently installed the Spring Update 1 ( the day it was released ) on my Windows 8.1 installation. This feature was working last Saturday today. I noticed that it wasn't.

The first thing I attempted to do was toggle the feature on and off. As you can see, the feature is indeed enabled. enter image description here

Here is my current session: enter image description here

After I close IE11 here is the startup session: enter image description here

I have attempted to look for people with similar problems. The problem I encountered I wasn't able to find anyone with this problem after they installed the Spring Update. Does anyone have any ideas on how to restore IE to start with my previous session?

I actually first noticed this problem today when IE11 didn't request to load my previous session ( this happen if you have a certain number of tabs ). I normally can figure a problem like this out.

At this point, I am stumped, and my head is sore from all the scratching I have been doing.

Update 1

Some additional information was discovered during some additional troubleshooting. I noticed that after closing Internet Explorer 11 an Internet Explorer process would remain running after the IE11 window was closed. If I manually end this process, IE11 can restore the previous session. If I don't, then IE11 is unable to load the previous session.

What is interesting is that this process does not show up within Process Explorer. Here is this "ghost" process that uses 0% of my CPU and only 29.3MB of memory. If I manually end this process, IE will always load the previous session.

enter image description here

Update 2

I was asked about which specific version I have installed currently:

enter image description here

I also attempted a new profile. By doing this, I had a minimal user profile and ruled out any issues with my current profile. This also means if I were to reset IE11, I likely would still have the problem. At this point I truly believe this to be a bug in Windows and some how connected to the Spring Update 1.

Here is a Piriform Speccy profile of my system: http://speccy.piriform.com/results/8m7q8iHMtSGrjEMlG2JPrOI

Update 3

Please don't link to this Microsoft Answer I just created it. If anything comes from it, I will either update the question or if I can resolve the problem, I will republish the answer here myself.

  • You could try to Reset Internet Explorer to Default. – harrymc Apr 16 '14 at 17:16
  • 1
    And what happens if you click Tools / Reopen last browsing session? – harrymc Apr 16 '14 at 17:35
  • Is "Enable automatic crash recovery" checked in Tools / Internet options / Advanced? If not, then turning it on might help. – harrymc Apr 16 '14 at 21:12
  • 4
    I have Win8+IE10 and these are my 2 cents: When Start with tabs from the last session is enabled I lose all open tabs in about 1 of 10 startups. Before I had this option disabled and I always manually activated menu item Tools > Reopen last browsing session after IE startup. In that case I was losing open tabs only very rarely (maybe every 300 launches). Until the problem is fixed, I suggest at least trying this workaround with manual restoring tabs after startup. – miroxlav Apr 17 '14 at 23:18
  • 1
    It would be wonderful to know the reason this question just got 2 thumbs down, besides the fact, I said something you didn't like. Please be kind, indicate the reason for your vote, I would rather not request it be disconnected from my account – Ramhound Sep 21 '15 at 21:39

I had the same problem as you have and the same system. I went to tools>>> Internet options>>> Advanced settings >>> Go to Enable Caret Browsing for new windows and tabs and put a check mark next to this. I did this and it opened my last browsing sessions. I couldn't before.

Hope this helps and if it doesn't then I would suggest to reset to default and then go back and check the Enable Caret Browsing again.


This seems to be an issue with Internet Explorer's core system, if your system will allow you to uninstall/re-install IE, I would do so.

You can usually do this in the Windows 'Turn Windows Features on or off' section.

  • Windows 8.1 ships with IE11 and doing the 'Turn Windows Features On or Off' would just revert IE to the default installed browser, which is IE11 and therefore can't really be done. – PTW-105 Apr 22 '14 at 22:10
  • 1
    WHY did anyone up-vote an answer to "uninstall IE" when it is universally known to be embedded in the system and therefore impossible to uninstall‽ Do not answer a question unless either you explicitly know the answer or the OP explicitly wants additional steps to troubleshoot. – John Aug 8 '15 at 21:18
  • This is not a " just un-install IE", you have now understood my answer. It is to un-install AND re-install to reset the browsers settings. Also, since Internet Explorer is IN the menu I provided, then you are saying it must be a false feature? I find that unlikely. – Stonestorm Aug 28 '15 at 10:03

After 18 months with this problem I ended up solving it. I solved it by doing an upgrade to Windows 10. This problem has not surface since I performed the upgrade.

Given that I had this problem across every single device that I installed Windows 8.1 on, and in every single case the problem was solved, when I upgrade to Windows 10, I feel it is safe to draw the conclusion the problem was simply fixed in the version of IE that comes installed on Windows 10.

I had 3 laptops of all difference brands running Windows 8.1, a Surface Pro 3, 1 virtual machine running Windows 8.1 Update, 1 main desktop running Windows 8.1 with all updates, and a 2nd virtual machine running Windows 8.1 with all updates installed.

Given that in every case resetting IE resulted exactly the same behavior I will conclude the bug was introduced in Windows 8.1 Update 1. As described in the question itself, this problem only surfaced AFTER, the machine was upgraded to the Fall 2014 Windows 8.1 Update ( aka Update 1 ).

  • 2
    People might say this isn't an answer to the proposed question, except the version of IE11 on Windows 10 is different from the version of IE11 on Windows 8.1 and upgrading to Windows 10 did solve my problem. I didn't give up, if there is a better solution out there post it, otherwise don't claim this isn't a solution to my problem. – Ramhound Aug 11 '15 at 13:03

Not the answer you're looking for? Browse other questions tagged or ask your own question.