I'm running Win 8.1 Pro x64. On April 9th, I was offered two updates from Microsoft. Usually, updates install automatically through Windows update but the following two updates, I noticed today (April 12th) are failing continuously with the error: 80073712. The updates are

  1. Security update for IE 11 (Kb2936068) 15MB
  2. Windows 8.1 Update (Kb2919355)

I have followed the resolution steps I found on the web and ran sfc /scannow which revealed everything is good.

I tried updating Kb2919355 manually using the standalone update utility and downloading the bunch of updates listed on the microsoft download center under this kb for Windows Update 8.1 but it doesn't install kb2919355 which is a 600+ Mb file saying nothing but some updates couldn't be installed.

I noticed that as soon as I run Windows Update using the Control Panel to try to download either of the above updates, it doesn't waste too much time and just comes back with the error 80073712. It doesn't even attempt to download the files completely and fails after 1 or 5%.

I have tried to review the WindowsUpdate Error log but its difficult to interpret and trying to google the failure messages in it has been making me run in circles.

My computer is running smoothly but I'd like to install those updates for satisfaction's sake. Otherwise, I might end up doing a fresh install but that's just too much hassle.

I'd appreciate the help and will share the logs that you ask. Thanks.

  • Try dism /online /cleanup-image /restorehealth
    – kinokijuf
    Apr 13, 2014 at 9:28
  • Did that already. /restorehealth says source files could not be downloaded.
    – Zain Ally
    Apr 13, 2014 at 9:53
  • Delete your CBS.log, run the command again and post it here
    – kinokijuf
    Apr 13, 2014 at 10:03
  • @ZainAlly: Even I'm facing similar issue (may be the error code is different) but I'm not able to install the Large Windows 8.1 U1 update. I also tried the restore health command as well the remove package command but yet trying to figure out the resolution
    – xorpower
    Apr 13, 2014 at 11:45
  • Did you mean DISM.log? I think CBS.log is generated by sfc /scannow - Anyway, I have uploaded fresh log files here. Just as an FYI - /restorehealth could not find the source to repair the componentstore and sfc said "no integrity violations". dl.dropboxusercontent.com/u/15931272/logs2.zip
    – Zain Ally
    Apr 13, 2014 at 11:50

7 Answers 7



I debugged this the last days several times. The fix is to run those 2 commands from a cmd, started as admin:

32Bit Windows:

dism /online /remove-package /packagename:Package_for_KB2919355~31bf3856ad364e35~x86~~
dism /online /cleanup-image /startcomponentcleanup


dism /online /remove-package /packagename:Package_for_KB2919355~31bf3856ad364e35~amd64~~
dism /online /cleanup-image /startcomponentcleanup

reboot and try to install the Updates again.

When it still fails, you can use the new Refresh/Reset feature (which removes all desktop applications but repairs the Windows Core) or the old InPlace Upgrade to repair Windows completely. This also keeps all desktop applications.

  • 1
    Didn't work for me. Here is the error on the first step: An error occurred trying to open - Package_for_KB2919355~31bf3856ad364e35~amd64~ ~ Error: 0x800f0805 The specified package is not valid Windows package. Error: 0x800f0805 The specified package is not valid Windows package. The DISM log file can be found at C:\WINDOWS\Logs\DISM\dism.log
    – Zain Ally
    Apr 13, 2014 at 7:46
  • DISM and CBS logs are here dl.dropboxusercontent.com/u/15931272/logs.zip
    – Zain Ally
    Apr 13, 2014 at 7:59
  • try to remove this update support.microsoft.com/kb/2898785/en-us before trying to install the large 8.1 update. Apr 13, 2014 at 8:14
  • that update is not installed. I tried running wusa /uninstall /kb:2898785 and it said "The update is not installed on this computer"
    – Zain Ally
    Apr 13, 2014 at 9:11
  • 1
    You still miss IE files with version 11.0.9600.16476 from KB2898785. Get a Win 8.1 ISO and do an inplace upgrade to repair Windows: sevenforums.com/tutorials/3413-repair-install.html Apr 16, 2014 at 18:03

If you have AVAST installed, deactivate it until installation is finished. That worked for me on 2 different computers.

  • Nope - I don't have AVAST.
    – Zain Ally
    Apr 14, 2014 at 3:44
  • Tried that, didn't work
    – surfen
    May 24, 2014 at 14:53

Users experiencing installation troubles should:

  1. Run sfc /scannow from an elevated command prompt
  2. Restart
  3. From elevated command prompt:

32Bit Windows:

dism /online /remove-package /packagename:Package_for_KB2919355~31bf3856ad364e35~x86~~

dism /online /cleanup-image /startcomponentcleanup


dism /online /remove-package /packagename:Package_for_KB2919355~31bf3856ad364e35~amd64~~

dism /online /cleanup-image /startcomponentcleanup
  1. Install April 2014 servicing stack update for Windows 8.1 and Windows Server 2012 & May 2014 servicing stack update for Windows 8.1 and Windows Server 2012 R2 & Fix Windows Update issues
  2. Run Clearcompressionflag.exe from http://support.microsoft.com/kb/2919355
  3. Restart
  4. Attempt installation of the update

If you are still getting installation failures you'll need to:

  1. Get ahold of a Windows 8.1 disk or ISO
  2. Complete a repair install/in-place upgrade. Be sure to allow the installer to download any updates. NOTE: this repair process will keep all of your data, apps, desktop apps, settings, etc. unlike others.
  3. Install all updates using Windows Update. You'll need to install updates & restart then look for more updates at least 4 times.

If you get an error message during your repair installation that says "we couldn't update the system reserved partition" you'll need to resize the small system reserve at the beginning of your drive using GParted:

  1. Install GParted on to a USB drive using the Tuxboot method
  2. Reboot your machine, make sure your BIOS is set to boot from USB first
  3. Press enter to all of the questions to accept the default responses until you get to the main GParted window
  4. Assuming your system only has two partitions, click the second box/partition, click resize/move, set the new size to about 300MiB less than the current size, set free space following to zero, select resize/move & select apply. Ignore any warnings it gives you about the risks of moving your main system partition, Windows 8.1 is smart enough to recover from these issues.
  5. Select the first box/partition (very small), click resize/move, set the size such that free space preceding and following is 0, select resize/move & select apply.
  6. Restart your machine and retry the repair install process.

This is what worked for me:

  1. Turn off automatic updates.

  2. Reboot.

  3. Press the windows key to get you into the tiled area (ie not desktop or explorer)

  4. Enter "update history"

  5. Select "View your update history for windows" which was my only option.

  6. When that history is showing, press the arrow key in the top left screen to take you out of that menu and into "Update and Recovery"

  7. Then select "Windows update" and "Check now".

  8. Wait and follow the screens.

It worked for me and I've been trying to install this KB2919255 for a week now.

  • Nope. This solution looked too simple to be true. Tried it twice with no success. The root cause issue now is the component store corruption. Unless it is fixed, I don't think there is a way to install these updates. dism /online /cleanup-image /restorehealth doesn't help in my case. It can't find the source files to restore.
    – Zain Ally
    Apr 15, 2014 at 22:43

I had the same problem.

I kept reaching 100%, but it would say that it didn't work, and it would revert. The removing of the package and cleanup wasn't working.

My problem was with the boot settings.

First, I removed and cleaned up once again.

Then, I went to run, and typed "msconfig", then the "boot" tab. The list was empty.

So I went to disk manager, and I gave a letter to the system partition. (I also have an ext4 partition, but I left that one as is, as windows couldn't see it.)


(I had some trouble rebooting the first time, so that the repair prompt came up, but I didn't do anything, just exited and loaded windows.)

After that, I was able to install the update.


Microsoft released a tool fix the issue: http://support.microsoft.com/kb/957310

Even if the tool said that it failed to fix the update, it fixed the issue where it did not allow the update.

After I ran the tool, I downloaded the update from Microsoft's website, and installed it manually. That worked perfectly for me.


After months of trying to resolve this we came up with a proven winner to get this installed. For our installations, our SonicWall VPN may have been the reason the install would fail.

  1. If you have a VPN installed, copy down all your domains and logins and UNINSTALL the VPN.

  2. Delete any corrupted instance of KB2919355 (this is using the 64 bit package) with an elevated command prompt using: DISM /online /remove-package /packagename:Package_for_KB2919355~31bf3856ad364e35~amd64~~

  3. Clean up with an elevated command prompt using: DISM /online /cleanup-image /startcomponentcleanup

  4. Download the Windows8.1-KB2919355-x64.msu and the clearcompressionflag.exe files. http://www.microsoft.com/en-us/download/details.aspx?id=42335 (again this is 64bit)

  5. Run clearcompressionflag.exe. Takes about 1 second and gives you no indication that it completed successfully, but thats ok.

  6. Run Windows8.1-KB2919355-x64.msu

  7. Restart Windows

  8. Bask in the glory of a successful install.

Not the answer you're looking for? Browse other questions tagged or ask your own question.