1

I just got Kali Linux working on my Macbook Pro (after much laboring). I reinstalled Kali after I wanted to repartition my HD to make it larger. I boot into rEFInd first, and load the bootloader (grub2) - which is placed on the Linux partition (and shows up as an option in rEFInd). I get to the normal grub load screen, select the linux version I want to load, and it begins to boot. At the very end, it tries to get into gdm3 (I think it succeeds) - but the GUI is never loaded - it just goes to command prompt. When I type gdm3 to try and load gnome - it displays this error:

=========================================================
WARNING **: Failed to acquire org.gnome.DisplayManager
WARNING **: Could not acquire name; bailing out
=========================================================

As I said - I am on a Macbook Pro (this one). Before I reinstalled - I previously had to hit 'e' during the grub menu so that I could add i915.modeset=0 - or else this problem would happen. But I had it working before (after the fresh install). I don't even think I changed anything - it seems like it just stopped working. I've tried without i915.modeset=0 and with i915.modeset=1 - right now the only default command I have is quiet.

The thing is, I used this guide (which was meant for a Macbook Air, but worked perfectly with my computer...at least initially) because I was running into all sorts of problems. Finally got it working with that method, and then I must have changed something to break it, but I don't remember changing anything at all. I remembered update-grub and I even tried update-initramfs (not sure if that is relevant to the problem).

My Partition Scheme (from OS X):

/dev/disk0
#:                       TYPE NAME                    SIZE       IDENTIFIER
0:      GUID_partition_scheme                        *500.1 GB   disk0
1:                        EFI EFI                     209.7 MB   disk0s1
2:                  Apple_HFS Macintosh HD            411.6 GB   disk0s2
3:                        EFI                         83.6 GB    disk0s3
4:                 Linux Swap                         4.0 GB     disk0s4

Also, in rEFInd - there is an extra logo representing "Linux on HD" which leads nowhere, I would like to know how to get rid of that as well (and maybe what it thinks it is haha).

To sum it up, I'm trying to get into the GUI for Gnome. Thanks!

0

I Isolated the problem with the help of the X server log file. It told me that there was a parse error in the xorg.conf file I had created for touchpad synaptics. I deleted that file - and everything is back to normal.

The extra rEFInd option was an EFI partition that I had on my external hard drive for some reason (not sure how it got there - I think diskutility may have made it when I tried to use it to partition my external to ext4). Isolated that problem by changing refind.conf (in os x) - uncommented #scanfor line, and only included internal - voila, the icon dissapeared, I am deleting the EFI partition on my external now so that it doesn't come back when I change back the refind.conf.

0

I have recently faced a problem with my kali linux, The problem is that i can't get into graphical mode, When ever i reboot my kali its starts in terminal mode(tty3) and asked root password when i typed password it still shows me text. i tried many things to get into graphical mode. Typing Startx to enter into graphical mode but it is used in backtrack not in kali. Later i tried pressing control+alt+f7 but still it didn't worked. After searching all websites and blogs i noticed many things Like some told to type "use fsck command then reboot, first login by entering your password" I tried fsck and came back with an error e2fsck cannot continue, aborting And even tried gdm3 but it didn't worked At some point i decided to reinstall the KALI. But i feared to lost the files in which i saved. Before typing

"apt-get update" and "apt-get upgrade"

to install missing files Let's check the Network connectivity by following steps

Service networking start Service Network-manager start Service samba start dhclient eth0

(ifconfig to check the net interface configuration is ok and eth0 is working right)

Then Update and Upgrade the kali..

Next install "chkconfig" if its not installed through

"apt-get install chkconfig"

Then check the status of level 2 of gdm3 using

"chkconfig --level 2 gdm3"

Install gdm3 service if it's not installed when i typed gdm3 it showed me "bash: gdm3:command not found" then i typed sudo

"apt-get install gdm3"

after installing i just typed

gdm3

in the terminal. Then it directly taken me to the graphical mode..

1
  • Could all this not be summed up as "gdm3 is probably missing. Install or reinstall gdm3." ? – killermist Jan 24 '15 at 17:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.