14

So, how to install i386 package on amd64 under the ubuntu/debian multiarch environment?

This is the follow-up for Why I can't see Ubuntu restricted packages, where the sl-modem-daemon package doesn't have the amd64 but only i386 version in Ubuntu. Following https://askubuntu.com/questions/29665/how-do-i-apt-get-a-32-bit-package-on-a-64-bit-installation, I tried,

apt-get install sl-modem-daemon:i386

but still get the reply that package not found.

  • Works on my machine. It is in restricted - did you enable that repository? – user55325 Apr 14 '14 at 4:59
  • No, so I guess the missing step is the "enabling that repository". How did you do that? – xpt Apr 14 '14 at 14:23
  • Start the "Software and Updates" tool (or go to the repository settings in Synaptic) and check the box called "Proprietary drivers for devices (restricted)". Then run apt-get update (if the package lists don't update automatically, which they might). – user55325 Apr 14 '14 at 21:48
  • As posted in superuser.com/questions/741368/…, I've enabled the restricted repository (details there). Are you using i386 instead of Amd64? – xpt Apr 14 '14 at 22:36
  • No, I'm using Kubuntu Saucy on amd64. Strange - if nothing else, assuming you have all the dependencies, you can always download the package and manually install it with dpkg -i --force-architecture. – user55325 Apr 15 '14 at 2:07
24

Found the answer in the Debian wiki (the ubuntu community MultiArch wiki is incomplete) -- https://wiki.debian.org/Multiarch/HOWTO. I.e., the step I'm missing is

To add an extra architecture (in Debian from dpkg 1.16.2 onwards):

dpkg --add-architecture <arch>

Having done that (and apt-get update of course), I'm now able to do apt-get install sl-modem-daemon:i386.

Thank you user55325 for riding the journey with me.

UPDATE: Found one that explains this explicitly:

How to enable 32-bit support for 64-bit Ubuntu 13.10 or greater
http://www.unixmen.com/enable-32-bit-support-64-bit-ubuntu-13-10-greater/

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.