4

I'm using Windows 8.1 64bit.

I know how enable Telnet-Client on Windows 8.1.

But when I type in :

telnet microsoft.com 80

nothing happens!

enter image description here

Any ideas would be appreciated.

  • switch to Putty. It is a better telnet client and does SSH. – Keltari Oct 30 '14 at 16:10
  • try seeing what's happening in wireshark – barlop Oct 30 '14 at 16:50
  • @Keltari yeah it's still pretty bad though in terms of features.. the command line interface is so limited with putty, that things like saving a profile, can be done in the gui but not in the command line. so putty's gui is more powerful than its command line. but yeah it's better than telnet. Do mention if you have a better client than putty. – barlop Oct 30 '14 at 16:52
1

Try running the following:

pkgmgr /iu:"TelnetClient"
| improve this answer | |
  • I tried your command but nothing changed ! – Hamed Kamrava Apr 14 '14 at 9:28
  • @HamedKamrava, what is the architecture of the machine you are trying this from? – user3227965 Apr 14 '14 at 9:46
  • x64-based processor – Hamed Kamrava Apr 14 '14 at 9:50
  • @HamedKamrava Does that return immediately back to the command prompt or does it flash the cursor for a few seconds – user3227965 Apr 14 '14 at 9:55
  • Immediately back to command prompt – Hamed Kamrava Apr 14 '14 at 10:06
0

You need to install additional components into Windows:

Settings > Control Panel

Go to the Programs category.

In Programs and Features, choose "Turn Windows features on or off".

A dialog box appears with a list of programs and a check-box next to each one. Scroll down the list to find "Telnet Client" and tick the box.

Then click OK to apply the changes.

| improve this answer | |
  • As I mentioned in the first post, I did enabled "Telnet Client"... – Hamed Kamrava Apr 14 '14 at 9:22
  • Ah, sorry. That is very unusual. No message? Just straight back to the prompt? I'd expect a "Connecting to ..." or a blank window with a blinking cursor. – njd Apr 14 '14 at 9:39
  • Unfortunately there no errors :( – Hamed Kamrava Apr 14 '14 at 9:41
0

I was having the same problem. To fix it, I just removed it via Add/Remove Windows Features, and then added it again.

| improve this answer | |
0

Try reinstalling telnet client by using DISM command:

dism /Online /Enable-Feature /FeatureName:TelnetClient
dism /Online /Disable-Feature /FeatureName:TelnetClient

See also: Install Telnet Client page.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.