18

I just directly connect my thin client (with embedded OS) to a remote machine (Windows 7) via RDP. The problem is, once I try to test the audio via Skype, it seems that the audio/microphone of the remote machine was hidden or not detected, but the remote audio was detected too because I could play music or videos. Is there a way to enable the microphone of the remote machine and used as the microphone of my thin client?

15

Before connecting to the remote computer, click on Show Options > Go to Local Resources tab > click Settings in the audio configuration. You can enable the recording from your local PC to the remote computer.

enter image description here

  • This is default in windows mstsc, should never be touched and the one thing everybody suggests on this problem everywhere on the internet. I'm surprised not one in here suggested to reinstall Windows. The thing is, if this was the actual real solution to the problem (no sound on remote), we wouldn't have so many with this problem. I have sound when I play Youtube videos on my remote, however Skype says not audio device is present. Some setting in MSTSC is not gonna change that – Christian May 24 '19 at 6:35
  • 3
    No, by default it is set to "Do not record", and apparently this did fix the issue to many people. Keep in mind the issue is the recording, not the playback. – Andrew May 24 '19 at 17:07
  • I agree I came of a bit better knowing - however, the problem is getting the mike working on the remote computer in Skype, not the sound in general. The fact that the Mike does not work on remote is also confirmed in another comment, further down. – Christian May 26 '19 at 13:23
  • My example on sound was to make the point, that even though I have enabled, "Play on this computer", I don't see any sound device in Skype on the remote. I suspect the same problem applies to the mike problem. – Christian May 26 '19 at 13:32
1

On desktop Windows clients, the mic setting is in the "new connection" dialog, under Local Resources / Remote audio [Settings...] / Remote audio recording: Record from this computer.

However, it sounds like you're trying to record audio on the remote computer, which is not an available option for the native clients. It's possible that other clients can support this feature, but it may also be a limitation of RDP, which would make it impossible.

  • can you elaborate for transferring audio in and out, am very sorry, I'm new with this. – Pooh poper Apr 14 '14 at 9:24
  • Audio out = speakers, audio in = microphone. What RDP client do you have? – trapezoid Apr 14 '14 at 9:33
  • here it is the setup, hence the thin client has an embedded os(xp) i used the default remote desktop to remotely connect my remote machine windows 7. And also in my hp thin client I connect a usb headset to used as audio and microphone since this is testing setup for a call center. But sad to say once I got connected via the rdp it seems the microphone is hidden or not detected when i tested on skype [under on audio settings: Microphone=>None] – Pooh poper Apr 14 '14 at 9:46
  • Are you trying to record audio from the thin client (possible), or from the remote machine (not possible)? – trapezoid Apr 14 '14 at 9:53
  • So it means, that we can't use the mic? okay, thank you for the information. – Pooh poper Apr 14 '14 at 9:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.