0

I am having Benq g925hda (18.5") monitor. And am running AMD processor in Gigabyte 78LMT-S2PT motherboard. Since today, my screen has gone back to 1024x768 resolution. The actual resolution that I was having before, was 1366 x 768. BTW, I only have one monitor.

Now, when I tried to put that resolution from the settings, I am not able to find it! I can only put 800x600 or 1024x768 resolutions. All other resolutions are giving out of range message.

enter image description here

I tried uninstalling and re-installing the display driver. Then downloaded the autodetect&download tool from AMD's site and found that the drive is latest!

Any suggestions on what I should try next?

Thank you

1

Given that it says (Default Monitor) it does not detect your monitor. Try unplugging the monitor and plugging it back is so plug and play can detect your monitor.

If unplugging and replugging the cable doesn't do it, restart your computer.

If that still doesn't do it, go to your device manager, unvold Monitors, right click the monitor and choose uninstall. Once done, reboot.

The monitor will now be found during the next reboot and your resolution will be selectable.

  • Thanks. I got it solved after uninstalling and restarting the pc like you said. – Akhilesh B Chandran Apr 15 '14 at 3:36
  • Again the display issue got back now. I have tried the previous solution of uninstalling(from Device Manager) and restarting the pc. But this time, it is not working! Tried it several times! The issue came back when I tried to shutdown pc, when uTorrent client was running I think. Because when shutting down, windows showed a message saying that there is some background applications running and was asking to force close or something. Any other suggestions? – Akhilesh B Chandran Apr 22 '14 at 17:17
  • uTorrent has nothing to do with this problem. Somehow it doesn't detect your monitor or the driver crashes. Lookup the driver for your monitor and install it manually. – LPChip Apr 22 '14 at 20:26
  • Yeah I know. But probably, it might have working in background causing the registry updations on shutdown getting corrupted. That was my doubt. But just now got it working all of a sudden when I opened it now. Not sure what happened though! Probably my os had auto updated the drivers? – Akhilesh B Chandran Apr 24 '14 at 11:19
  • Yeah, that is very likely. – LPChip Apr 24 '14 at 11:47

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.