0

So I got brew on my mac and I had tmux installed and running just fine. Then after I refreshed my system every time I try to run tmux i get this error:

"-bash: tmux: command not found"

So since I'm kinda new to linux or unix based systems in general I'm having problems getting it to work. I got "tmux.conf" file in place but that doesn't seem to help.

Any takers on this one?

UPDATE:

per request from the comments.

echo $PATH

gives me

/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin:/opt/X11/bin

brew command also works

  • First run a "locate tmux" from the command line to see if the binary is installed. You may need to update the locate database if you haven't ran that command before. – skub Apr 15 '14 at 0:10
  • So I ran "locate tmux" and it told me that the database didn't exit in /var/db/locate.database I ran sudo launchctl load -w /System/Library/LaunchDaemons/com.apple.locate.plist to create it and it took it but then I ran locate tmux again and it gave me the same thing that the database wasn't created yet.. – ldimans Apr 15 '14 at 0:41
  • Oh.. apparently it created the database after a while.. but now what do i do? – ldimans Apr 15 '14 at 0:52
  • Does the brew command work? What's the output of echo $PATH? Please edit the question and include that info. – slhck Apr 15 '14 at 12:10
  • What do you mean by 'refreshed my system'? brew should usually install things and link them in /usr/local/bin. Try brew list tmux. If it's installed, it'll show up. If it shows up but you can't find tmux in /usr/local/bin/ try brew link tmux – harithski Apr 16 '14 at 5:17

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.