0

I have a D-LINK nas (Linux 3.2.34 armv7l), where I have screen, compiled from sources. Everything was fine until something happened and now I can't resume the session. The symptoms are as follows

[root@nas:~]$ screen -ls
There is a screen on:
    13894.tty.NAS   (Detached)
1 Socket in /tmp/screens/S-root.

[root@nas:~]$ screen -r
[root@nas:~]$ screen -r 111
There is no screen to be resumed matching 111.
[root@nas:~]$ screen -r 13894
[root@nas:~]$

So, as you can see, the session is detached, but when I "screen -r" nothing happens at all, not even an error message. If i enter the wrong session name however, it correctly says so, but still, nothing happens when I enter the correct session id.

What could it be?

UPD: I've tried all the parameters from the manual, such as "-D -R", "-DRR" etc. The result is not changing

0

Try forcing the action:

$ screen -D -R

From the screen(1) manual page:

   -D -R   Attach  here and now. In detail this means: If a session is running, then reattach. If necessary detach and logout remotely first.  If it was not running create it and notify the user. This is the author's
           favorite.
| improve this answer | |
  • Nope, still nothing. I've tried everything from the manual – Roman Usherenko Apr 15 '14 at 15:17
  • Does the socket still exist? – dawud Apr 15 '14 at 15:50
  • yes, the 'screen -ls' verifies it. also it's physically there – Roman Usherenko Apr 15 '14 at 20:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.