0

I am using a HP Pavilion laptop pre installed with Windows 8. I am trying to install Ubuntu 13.04 on my laptop using a LiveUSB, which I created in the conventional way given on the Ubuntu official site.

The problem is that even after changing the boot order to USB Stick in my BIOS, my system doesn't boot from the LiveUSB. It boots directly from the HDD, due to which I don't see the grub menu and system is automatically booted in Windows 8.

I tried the same USB on a different system (my assembled desktop which doesn't support UEFI), and it works fine there. The problem occurs only on my HP laptop.

Please help. Thanks in advance.

P.S. I tried installing Ubuntu from Wubi, but then there's a whole different altogether. During boot, it shows an Ubuntu option, but reports a missing file.

0

I've had the best success on both UEFI and Legacy BIOS when using the latest version of Unetbootin.

It seems older Unetbootin versions have difficulties with different booting methods, as well as some ISOs themselves (such as Windows).

On a spare HP laptop I found lying around (on which I had a similar issue installing Linux), I press the ESC at boot and then press F9 to select the boot device. I've only had success on this laptop using the latest version of Unetbootin.

1
  • Sorry I didn't yet try Unetbootin. But when I enabled Legacy and disabled Secure Boot option in BIOS, my LIVEUSB was detected successfully. That was the basic problem I was facing. – Neil Apr 17 '14 at 14:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.