0

I have just installed ESXi 5.1 update 2 on my home server, but the host keeps disconnecting after a few seconds to a couple of minutes. I have gone through all the troubleshooting steps on the vmware website to no avail.

Right now I have disabled the firewall both on the client machine and on ESXi itself so there is nothing in between them. The cables are working, the router is working, the drivers are installed etc.

Has this happened to anybody else? I am hoping somebody can point me in the right direction here.

When I say that the host is disconnected, I mean that it is disconnected from the local network, so my vSphere client cannot connect to it anymore. The only way to "solve" this is to reboot the server on which ESXi is installed on. Only to see it disconnect after another minute, that is.

5
  • Have you tried just re-installing ESXi from scratch? – Josh Apr 16 '14 at 20:59
  • @JoshR Let me try that too, i'll do it right now – user1301428 Apr 16 '14 at 21:28
  • What do you specifically mean when you say that it's disconnecting? Do you mean that your vSphere client is disconnecting from the host? Do you mean that your vCenter server (if you have one) is showing the host as disconnected? Do you mean that the host loses it's network connection? Details, please. – joeqwerty Apr 16 '14 at 21:30
  • @joeqwerty You're right, question updated, I should have clarified better. I have read so many posts online about this that I gave this information for granted :D – user1301428 Apr 16 '14 at 21:59
  • @JoshR I have tried installing version 5.5 from scratch (hoping it might be a bug in 5.1) but I still see the same behavior.. – user1301428 Apr 16 '14 at 22:12
0

I had some very strange network problems on my homeserver too, such as disconnects and no internet access with static ip. After EXSi 5.5 failed to install (no network card found - the box had 2!) I used ESXi Customizer (just google it) to embedd my network card drivers into the iso (finding them may require you to google again ;) and since then all problems disappeared.

PS: Don't give up on ESXi, when it is (finally) running it's very good, I can't imagine another OS for my homeserver any more ;)

4
  • Yeah, I absolutely want to use ESXi, it makes running a home server a much better experience. I did use ESXi customizer to inject my network card drivers (version 5.5 didn't have them, but version 5.1 did), and in fact installation works, i.e. the network card is detected. The problems start when I actually boot it :( – user1301428 Apr 17 '14 at 6:48
  • This makes it more difficult. When it's disconnected, is the service interface (the ui at the server) still able to ping something and what ip does it show? – Sebb Apr 17 '14 at 13:28
  • No, the machine was not pingable and it could not ping either, not even a gateway. I found a solution though, see my answer, but thanks for the suggestion! – user1301428 Apr 17 '14 at 15:56
  • Goood luck for your further experiments ;) – Sebb Apr 17 '14 at 20:02
0

Ok, I found a temporary solution (it's been working so far so I thought it might be worth posting).

My NIC uses the Realtek 8111G drivers, which are not supported by ESXi. Installing the 8168 or the 8169 drivers did not work (meaning that the NIC was recognized, but it kept disconnecting).

I found a post on the vmware community forum in which a user suggested to leave the gateway field of the host empty. I don't know if it will last long, but at least the situation is much better than before.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.