10

I'm stumped as to how the search function is Windows 8 File Explorer is supposed to work.

I'm trying to search the content of some text files under a sub-folder of My Documents. In File Explorer (from the desktop) I've typed the search string in the search box. No results. I know that multiple files in the sub-folder contain the text I'm looking for; I opened a couple just to check.

I then went into the Advanced options on the File Explorer Search Tools ribbon bar, ticked File contents, then repeated the search. No results.

I then Googled the problem, which suggested I should index the folder containing the files I wanted to search. So I went into the Search Tools ribbon bar > Advanced options again, and clicked on Change indexed locations. I discovered that all the sub-folders of My Documents are being indexed already (and I double-checked that particular sub-folder was being indexed).

I thought perhaps the text I was searching for, "import" (without the quotes), might have been a reserved word or something so I tried searching for other text I knew appeared in multiple files, "datetime". Still no results.

Any ideas about what I'm doing wrong and how to get file content search working?

  • 5
    I have exactly the same problem. It's a real pitty that Microsoft decided to break such a core functionality. Searching file content was so easy in previous Windows versions and now it's harder than rocket science. Windows 8 sucks big time :(. – Michael Härtl Aug 27 '14 at 8:45
7

You could try this :

In Explorer

1- Menu View
2- Click Options
3- Click Search tab
4- Select "Always search file name and contents"
5- Click "OK"

2

Agreed, MS broke something that worked. But try this in the search window adjacent to the file path window. The following searches all .docx files for the string 'fish'.

*.docx content:fish

I haven't figured out how to make it case sensitive or whole words only but better than nothing. I am sure there are other arguments besides 'content' like 'date', 'size' but haven't found the list.

Works for Windows8, not sure about Windows10

  • Still doesn't work perfectly for me. I tried – SimonTewsi Jan 28 '18 at 20:59
  • [whoops, hit Enter too soon] Still doesn't really work for me. I tried content:datetime which returned 1 hit where there should have been many more. I then searched with PowerShell Get-ChildItem in the same folder tree which returned 13 hits. The single hit was in a sub-folder, not the root folder of the search, so Windows wasn't just searching the root folder and not sub-folders. I did notice the single hit was in an XML document whereas all other files in the tree were PowerShell files (.ps1, .psm1, .psd1). I then tried *.ps1 content:datetime but that returned 0 hits. – SimonTewsi Jan 28 '18 at 21:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.