0

Recently, M-2 (and the other M-N's) have stopped working for me in tmux. M-Up, M-Down, etc still work. It only seems to affect the M-NumberKey key chords.

I can run:

select-layout even-vertical

from the : prompt and it still works...

The keybindings still seem correct:

bind-key        M-1 select-layout even-horizontal
bind-key        M-2 select-layout even-vertical
bind-key        M-3 select-layout main-horizontal
bind-key        M-4 select-layout main-vertical
bind-key        M-5 select-layout tiled

I'm guessing it might not actually be tmux's fault since I haven't updated tmux recently, but I have no idea how to debug this...

I've tried with several terminal emulators (gnome-terminal, xterm, xfce4-terminal) in two different desktop environments (Gnome and XFCE4).

Any ideas on what's going on here or how I can debug this?

Other possibly useful info:

tmux version: 1.9a
Distro: Arch Linux
  • Have you tried completely quitting tmux (or rebooting), and still gotten the issue? – demure Apr 19 '14 at 23:06
  • Yes. Turns out it's a bug in gnome-terminal with the GNOME 3.12 release. – mgalgs Apr 20 '14 at 3:32
0

Turns out it's a bug in gnome-terminal with the GNOME 3.12 release. Bug description and workaround here. Spoiler: disable the Alt-<N> keyboard shortcuts in Edit -> Preferences -> Shortcuts.

  • Terminator has a similar poor default, where you have to disable it's use of alt+arrows – demure Apr 22 '14 at 2:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.