I've searched high and low for this fix but no cigar. I recently installed a new motherboard (MSI Z77A-G45 Gaming mobo) and now Visual Studios won't load past the white splash screen that says "Visual Studio".

I believe it could be related to a problem with Secure Download Manager, as since the I installed the new mobo, it displays "Navigation to the webpage was canceled". I'm using SDM to download VS because I got VS for free on Dreamspark, so there's a problem, I can't redownload it because I can't run the downloader (what happened to direct downloads?).

Here's the kicker: After several problems after switching motherboards, I suddenly remembered to reinstall windows. However, due to the way I originally (a few years ago) set up my computer, I couldn't wipe my primary hard drive and had to learn to do it with command prompt in the Windows Recovery thingy (can't remember the name at the moment).

Due to the beginners luck, I wiped every single partition and drive on my computer (oops) and, as a result, everything is fresh.

I'm tempted to say bad motherboard, as that's the recent change that threw my world into chaos (i'm already down 3 assignments in class), but waiting for a new one and then it not being the case is a severe waste of time and resources.

On top of that, it doesn't appear to be hardware related, so it has to be something I forgot to install that is both screwing with VS and SDM, but would allow my computer to function normally otherwise. It's possible it's also causing problems with my inability to connect to Steam without using -tcp protocols, but I wouldn't hold my breath, Valve seems to be disappointing me a lot lately.

UPDATE: I can open up Blend just fine, too bad I don't use it... (yet).

  • The only thing that SDM requires an internet connection.
    – Ramhound
    Apr 17, 2014 at 4:06
  • Interesting, because after reinstalling windows, I ran into some internet hiccup, so to speak. Everything slowed down and pretty much stopped; only internet explorer worked and it worked slow (ironic right?) However, it wasn't just my computer, but every device on this internet connection slowed/stopped. It happened like 2 times that day and never since. Apr 17, 2014 at 4:21
  • No one else ran into this problem with VS13? Apr 17, 2014 at 20:11
  • No; a computer on the network isn't going to slow other devices on the network you have something else going on. I still maintain all SDM requires is an internet connection
    – Ramhound
    Apr 17, 2014 at 21:48
  • You're missing the problem: I can't start VS2013. If we fix that, then I don't need to fix the problem with SDM (at least, not yet). The only reason I said the two were related is because I have to use one to download the other. I have the install already, the only reason I would need SDM would be to download the install again. Apr 18, 2014 at 4:55

7 Answers 7


I had this issue on vs 2015 RTM. I used devenv /resetuserdata and it started.


I had the same problem on VS2015 community and solved it by doing this:

  1. Run in command prompt: devenv /ResetSettings (it runs VS by some package error)
  2. After VS runs, you must update some things that noticed by flag up right (for me Powershell tools)
  3. After updating those things, Visual Studio restarts and everything should be solved.

I think for this solution to work, you must force VS to restart.

  • I used the /Setup switch to get my 2015 instance to launch. Dec 9, 2015 at 20:26

I seem to have a similar problem but unrelated to any hardware changes. However I just installed Windows 10 CTP and then Visual Studio 2013 Premium. I installead, booted and tried to start Visual Studio. A short splash screen and then a white dialog with an X.

The same problem is described here: https://connect.microsoft.com/VisualStudio/feedback/details/807911/visual-studio-2013-professional-fails-to-start

The solution in the connect thread is to uninstall some applications - I don't have any of those and it's a pretty fresh installation.

I've tried to start with devenv /ResetSettings and it starts but gives me two errors: * The 'Microsoft.VisualStudio.Shell.Connected.ConnectedUser.ConnectedUserPackage' package did not load correctly. * The 'Microsoft.VisualStudio.TeamFoundation.TeamFoundationHost,Microsoft.VisualStudio.TeamFoundation,Version=,Culture=neutral,PublicKeyToken=b03f57f11d50a3a' package did not load correctly.

After these error messages the IDE is somewhat responsive but alot of things does not work. The "Sign in" button in the upper right corner does not work. I believe that the white dialog that is displayed when VS2013 freezes is the "Sign into your Microsoft account" dialog.

Blend starts fine and seems to work as expected.

Any ideas?

  • Repair didn't work. Modify didn't work. Windows update didn't work. Reinstall didn't work. Uninstall + reinstall from Web Installer DID WORK. So that's the tip: don't use the iso that bundles Update 3.
    – mikeesouth
    Oct 3, 2014 at 21:53
  • devenv /ResetSettings worked for me. Thanks
    – Whoever
    Feb 4, 2015 at 16:57

I ran the following command and it at least started:

"C:\Program Files (x86)\Microsoft Visual Studio 12.0\Common7\IDE\devenv.exe"  /SafeMode

In my case it was a missing file machine.config in C:\Windows\Microsoft.NET\Framework\v2.0.50727\CONFIG. I copied the file from another PC and installation immediately started, and completed successfully.


I am running in Windows 7 with VS2013 Ultimate. I had the same issue with no visible error message. Booting in /SafeMode worked just fine, but didn't fix the problem. I uninstalled and reinstalled VS2013 Ultimate and it didn't help either.

What I finally noticed was that somehow VS2013 got set to compatibility mode for Windows XP under all users:

Properties -> Compatibility -> Change Settings for all users

Unchecking compatibility mode fixed the start-up problem on my machine.


In case any of the other solutions don't work, be sure to check your PATH system environment variable. I have a ton of development tools installed and it never fails that when I install something new, I go over the 2048 character limit.

I end up having to create "substitution" environment variables as shortcuts that I can then use in my full system path.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .